1

I'm trying to remove the editor from the bibliography by setting useeditor=false. However, this option seems to have no effect, neither when set globally, nor per entry.

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[backend=biber]{biblatex}
\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@INBOOK{key4,
  AUTHOR          = {Author},
  TITLE           = {Orig Language Title},
  BOOKTITLE       = {Booktitle},
  LOCATION        = {Location},
  PUBLISHER       = {Publisher2},
  DATE            = {2011-22},
  PAGES           = {33--57}
}
@INPROCEEDINGS{Chunyuan2017,
  author = {Li, Chunyuan and Liu, Hao and Chen, Changyou and Pu, Yuchen and Chen, Liqun and Henao, Ricardo and Carin, Lawrence},
  booktitle = {Advances in Neural Information Processing Systems 30},
  editor = {Guyon, I and Luxburg, U V and Bengio, S and Wallach, H and Fergus, R and Vishwanathan, S and Garnett, R},
  pages = {5495--5503},
  publisher = {Curran Associates, Inc.},
  title = {{ALICE: Towards Understanding Adversarial Learning for Joint Distribution Matching}},
  year = {2017}
}
@ARTICLE{Botta2014,
  author = {Botta, Vincent and Louppe, Gilles and Geurts, Pierre and Wehenkel, Louis},
  title = {{Exploiting SNP Correlations within Random Forest for Genome-Wide Association Studies}},
  doi = {10.1371/journal.pone.0093379},
  editor = {Chen, Lin},
  issn = {1932-6203},
  journal = {PLoS ONE},
  month = APR,
  number = {4},
  pages = {e93379},
  volume = {9},
  year = {2014}
}

\end{filecontents}
\addbibresource{\jobname.bib}

\ExecuteBibliographyOptions{useeditor=false}

\begin{document}
\nocite{*}
\printbibliography
\end{document}

I tried with biber 2.11 and biblatex 3.11 as well as the latest version (biber 2.14 and biblatex 3.14). Both give the same result:

generated PDF

I've also tried useauthor=false, which works.

Any ideas what is going wrong?

3

useeditor=false does not remove the editor from the bibliography. If it takes effect at all, it just moves it around a bit and prevents the editor from taking the author position for sorting and label generation

The documentation explains the option as follows

[useeditor] Whether the editor replaces a missing author in labels and during sorting. This may be useful if an entry includes an editor field but is usually not cited by editor. Setting useeditor=false does not mean that the editor is ignored completely. It means that the editor does not replace a missing author in labels and during sorting. The entry will then be alphabetized by title. With the standard styles, the editor is printed after the title in this case.

You can see the effect of useeditor in the following example

\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[style=authoryear, backend=biber]{biblatex}

\begin{filecontents}[force]{\jobname.bib}
@mvcollection{britannica:simplified,
  editor       = {Preece, Warren E.},
  title        = {The {New Encyclop{\ae}dia Britannica}},
  date         = {2003},
  edition      = 15,
  volumes      = 32,
  publisher    = {Encyclop{\ae}dia Britannica},
  location     = {Chicago, Ill.},
  options      = {useeditor=false},
  label        = {EB},
  sorttitle    = {Encyclop{\ae}dia Britannica},
}
\end{filecontents}
\addbibresource{\jobname.bib}
\addbibresource{biblatex-examples.bib}

\begin{document}
\cite{britannica:simplified}
\nocite{cicero,nussbaum,sigfridsson}
\printbibliography
\end{document}

With useeditor=false britannica:simplified is cited as

EB 2003

and sorted under "E" (due to sorttitle = {Encyclop{\ae}dia Britannica},) because the editor does not replace the missing author field (so label is used as a fallback).

But with useeditor=true the citation is

Preece 2003

and the work is sorted under "P".


If you want to remove the editor, that is best done via a Biber sourcemap.

\documentclass{article}
\usepackage[backend=biber]{biblatex}

\DeclareSourcemap{
  \maps[datatype=bibtex, overwrite]{
    \map{
      \step[fieldset=editor, null]
    }
  }
}

\begin{filecontents}[force]{\jobname.bib}
@INBOOK{key4,
  AUTHOR     = {Author},
  TITLE      = {Orig Language Title},
  BOOKTITLE  = {Booktitle},
  LOCATION   = {Location},
  PUBLISHER  = {Publisher2},
  DATE       = {2011-22},
  PAGES      = {33--57}
}
@INPROCEEDINGS{Chunyuan2017,
  author    = {Li, Chunyuan and Liu, Hao and Chen, Changyou
               and Pu, Yuchen and Chen, Liqun and Henao, Ricardo
               and Carin, Lawrence},
  booktitle = {Advances in Neural Information Processing Systems 30},
  editor    = {Guyon, I. and Luxburg, U. V. and Bengio, S.
               and Wallach, H. and Fergus, R. and Vishwanathan, S.
               and Garnett, R.},
  pages     = {5495--5503},
  publisher = {Curran Associates, Inc.},
  title     = {{ALICE}: Towards Understanding Adversarial Learning for Joint Distribution Matching},
  year      = {2017},
}
@ARTICLE{Botta2014,
  author  = {Botta, Vincent and Louppe, Gilles and Geurts, Pierre and Wehenkel, Louis},
  title   = {Exploiting {SNP} Correlations within Random Forest for Genome-Wide Association Studies},
  doi     = {10.1371/journal.pone.0093379},
  editor  = {Chen, Lin},
  issn    = {1932-6203},
  journal = {PLoS ONE},
  month   = APR,
  number  = {4},
  pages   = {e93379},
  volume  = {9},
  year    = {2014}
}

\end{filecontents}
\addbibresource{\jobname.bib}

\ExecuteBibliographyOptions{useeditor=false}

\begin{document}
\nocite{*}
\printbibliography
\end{document}
| improve this answer | |
  • \DeclareSourcemap is exactly what I was looking for, thanks a lot. – sebp Jan 2 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.