2

I have a problem with the joined use of svmono class from springer link and the babel package. When I activate the babel package it produces the error:

"Missing \begin{document}. \newlabel{Einleitung}{{1}{1}}["

MWE:

\documentclass[graybox,table,envcountchap]{svmono} 
\usepackage[ngerman]{babel}

\begin{document}
\chapter{Einleitung}
\label{Einleitung}
Test
\end{document}

However, no error is produced with the babel package excluded. Anyone experienced the same issue or has a solution?

Link to SVMONO class I use

2
  • 1
    I get no error from the example, only a warning about the table option, which is unknown to the class. Delete the .aux file and retry.
    – egreg
    Jan 3, 2020 at 16:10
  • You are right it works. Actually I just realized, I downloaded the svmono class from the German Springer Site. Looks all the same, but produces the upper mentioned bug. But the one from the site provided with the link everything is fine! And it also contains the German expressions. So problem solved! Thx. for your reply! :)
    – kilsen
    Jan 3, 2020 at 16:23

2 Answers 2

1

You've linked to an outdated svmono version. (Do complain to Springer for linking something outdated!) Springer is not very good at maintainig this class, but, anyway, as these lines are written, feel free to get an updated version 5.6 from http://www.springer.com/gp/authors-editors/book-authors-editors/resources-guidelines/book-manuscript-guidelines/manuscript-preparation/5636 .

You've also forgotten to use the class option deutsch.

With class version 5.6, the error occurs. Complain to Springer again; it's their fault. (In my view, they bath in money from the libraries and can allocate a bit more of it to support LaTeX better.) After complaining, comment out ntheorem stuff at lines 2036 till 2042, right after "SOPHIE TEMPLATE ENDS". ntheorem has bugs and is outdated and nonmaintained since, I think, 2011. Removing ntheorem, you will have to deal with the consequence that labeling and referencing theorem-like environments will require more manual work, but this is a better option than failing compilation.

The only alternative I can imagine is that someone repairs ntheorem ...

3
  • Thanks for the link! This was actually the svmono class I was using and with this one it produces the error (after second compilation) mentioned above! So the old one works, the new one does not.
    – kilsen
    Jan 3, 2020 at 16:34
  • Thanks again! The solution works. I will suggest an update to Springer.
    – kilsen
    Jan 5, 2020 at 13:50
  • @kilsen Using a hacked class brings little if you have to submit the sources. The class file should be properly rewritten by Springer in first place.
    – user203414
    Jan 5, 2020 at 15:50
1

The awnser from Springer: “\usepackage{hyperref}” before the “babel” solves the problem.

\documentclass[graybox,table,envcountchap]{svmono} 
\usepackage{hyperref}
\usepackage[ngerman]{babel}

\begin{document}
\chapter{Einleitung}
\label{Einleitung}
Test
\end{document}
1
  • Note that in hyperref.pdf, file dated 2018-11-30, document dated September 2018, in §5.26 babel is loaded before hyperref.
    – user203414
    Jan 12, 2020 at 19:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .