0

I have started to use book.cls instead of llncs.cls. I have copied the content of book.cls from here.

For some reason, the pdf output has the even pages aligned to the right while the odd pages are (correctly) aligned to the left.

See the following zoomed-out pdf for example: enter image description here

in this example the first page on the image is an even page so it is aligned to the right. I would like all pages to be aligned as in the second page (which has odd number).

I have the following before \begin{documnet}:

\let\oldvec\vec

\documentclass[ruled,vlined,linesnumbered,commentsnumbered]{book}

\let\vec\oldvec

\usepackage[ruled,vlined,linesnumbered,commentsnumbered]{algorithm2e}
\usepackage{amsmath,amssymb,amsfonts,amsthm}
\usepackage{graphicx}
\usepackage{setspace}
\usepackage{tocloft}
\usepackage{etoolbox}
\patchcmd{\thebibliography}{\chapter*}{\section*}{}{}
\renewcommand{\thesection}{\arabic{section}}
\renewcommand{\cfttoctitlefont}{\large\bfseries}
\setlength{\cftsecindent}{0em}
\setlength\cftaftertoctitleskip{8pt}
\setlength{\cftbeforetoctitleskip}{-3em}
\renewcommand\cftloftitlefont{\large\bfseries}
\setlength{\cftafterloftitleskip}{1\baselineskip}
\setlength{\cftfigindent}{0pt} 

\pagestyle{plain}
\pagenumbering{arabic}
\newcommand {\ignore} [1] {} 
\newtheorem{theorem}{Theorem}
\newtheorem{lemma}{Lemma}
\newtheorem{corollary}{Corollary}
\newtheorem{remark}{Remark}
\newtheorem{definition}{Definition}

What could be the reason and how can I fix this problem ?

  • 2
    In the book class outer margins are wider than inner margins. That's perfectly normal (and a FAQ). – egreg Jan 5 at 20:09
  • 2
    If you don't like the fact that book.cls is using a two-sided layout, you can disable this by using the oneside class option. – Skillmon likes topanswers.xyz Jan 5 at 20:15
  • 1
    you don't need to copy book.cls from anywhere, it is a core latex file you should use the book.cls that comes with your latex system – David Carlisle Jan 5 at 20:48
  • open up most books and you will see this layout with the position of the text block on the right hand page being a mirror of the position on the left. – David Carlisle Jan 5 at 20:50
2

As @egreg mentioned in his comment, this is the normal and expected behaviour for a book, as you want the outer margins to be roughly as wide as the two inner margins in sum. This gives a balanced look in duplex print and matches what is considered as good typography.

If you want to disable this behaviour it suffices to provide oneside as a class option:

\documentclass[oneside]{book}

\usepackage{duckuments} % just for dummy content, otherwise not needed

\begin{document}
\duckument % dummy content
\end{document}

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.