I installed recently LyX with MiKTeX and executed an external program that changed the definitions so that I can export with foreign languages.

While exporting (using "pdflatex") works great, the view option stopped working and I suspect the external program is to be blamed. My computer is x64 system based.

My LyX version info:

LyX Version 2.3.1-1

(Saturday, September 29, 2018)

Library directory: C:\Program Files (x86)\LyX 2.3\Resources\

User directory: ~\AppData\Roaming\LyX2.3\

Qt Version (run-time): 5.10.1

Qt Version (compile-time): 5.10.1

The error log reads:

The external program pplatex finished with an error.

It is recommended you fix the cause of the external program's error (check the logs).

12:08:57.934: Error while exporting format:

PDF (dvipdfm) 12:09:39.663: (buffer-switch C:/Users/~/OneDrive/Documents/newfile1.lyx)

12:09:51.914: (dialog-toggle progress)

12:10:57.364: Automatic save done.

12:15:57.397: Automatic save done.

12:16:47.470: (dialog-show aboutlyx)

12:20:57.425: Automatic save done.

I also receive a system error

titled: pplatex.exe - System Error

The code execution cannot be proceed because MSVCR100.dll was not found.

reinstalling the program may fix this problem.

The file is not in the latex bin folder but when I copied the file from C:\Windows\System32 it still didn't work.

I tried adding C:\Windows\System32 to the Lyx path or installing Microsoft Visual C++2010 Redistributable Package and still nothing seemed to work.

Maybe an easier way will be to change "view" default from pplatex to pdflatex but I have failed to find how it is done.

1 Answer 1


A temporary fix is to use the "view as" button and pick each time pdflatex option. But i'd like to be able to use the short cut ctrl+R

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .