2

I installed TeX Live manually on Ubuntu 18.04 (using the script from http://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz). Now I want to use LuaLaTeX to compile documents like this one:

\documentclass{article}

\begin{document}
        Hello world!
\end{document}

However, if I execute LuaLaTeX with this document using lualatex main.tex, there is no PDF file generated, but also no errors:

This is LuaTeX, Version 1.10.0 (TeX Live 2019) 
 restricted system commands enabled.
(./main.tex
LaTeX2e <2019-10-01> patch level 3

The only file generated is main.log:

This is LuaTeX, Version 1.10.0 (TeX Live 2019)  (format=lualatex 2020.1.9)  9 JAN 2020 11:55
 restricted system commands enabled.
**main.tex
(./main.tex
LaTeX2e <2019-10-01> patch level 3
Lua module: luaotfload-main 2019-11-10 3.11 luaotfload entry point
Lua module: luaotfload-init 2019-11-10 3.11 luaotfload submodule / initialization
Lua module: lualibs 2019-11-06 2.69 ConTeXt Lua standard libraries.
Lua module: lualibs-extended 2019-11-06 2.69 ConTeXt Lua libraries -- extended collection.
Lua module: luaotfload-log 2019-11-10 3.11 luaotfload submodule / logging

Compilation with pdfLaTeX or XeLaTeX works without any problems. Does anybody know what the problem might be?

  • Does the log-file really ends like this or is there more? – Ulrike Fischer Jan 9 at 13:26
  • @UlrikeFischer That's all. – Felix Schütz Jan 9 at 14:37
  • Hm. Did you install a full texlive? – Ulrike Fischer Jan 9 at 14:46
  • @UlrikeFischer Yes, I did. Maybe I should try to install it again. – Felix Schütz Jan 9 at 14:51
  • What happens if you run luaotfload-tool -u -vvv? – Ulrike Fischer Jan 9 at 14:54
3

luaotfload needs to store some caching related files which are normally stored in $TEXMFVAR, the directory reserved in TeX Live for generated data. For that, you need to give LuaTeX write access to this directory.

There are basically two reasons why this might not be the case:

  • You have some very special setup where you are not allowed into your own home directory, so TeX can't create the default TEXMFVAR at ~/.texlive2019/texmf-var.
  • Or you changed the location of TEXMFVAR while installing TeX Live (or afterwards) and the new location isn't writable.

    You can see if your TEXMFVAR has been changed by looking at the file texmf.cnf in your TeX Live installation directory, e.g. /usr/local/texlive/2019/. If there is a line starting with TEXMFVAR, you have a customized TEXMFVAR and you have to ensure that this directory can be written to.

    If you don't have any good reason for changing the default, the easiest fix often is to restore the default setting by removing this line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.