0

I have some problems with custom font encoding, mainly texnansi. I made a custom font from ttf. Since I have heavy usage of Umlauts, I figured out that texnansi may be the right choice. Maybe I am wrong there already. For several reasons the document needs to be Koma compiled with pdflatex. I made a minimal example showing the problem:

  \documentclass[a4paper, 10pt, sectionprefix, ngerman]{scrbook}
  \usepackage{texnansi}  % <---- comment this out
  \pagestyle{empty}
  \pdfmapfile{=augie8y.map}
  \newcommand{\fancyfont}{\fontfamily{augie}\selectfont}
  \usepackage{multicol}
  \begin{document}
  \fancyfont custom Font here \\
  \normalfont
  \textbf{bold text here} \\
  normal text here
  \begin{multicols}{4}
  überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur
  \end{multicols}
  \end{document}

As soon \usepackage{texnansi} is used, the bold font isn't bold anymore. If I remove the texnansi package the font is bold again, but instead of the German hyphenation is broken. Any suggestions on how to fix it?

In case it matters, there are some warnings about undefined font shapes:

LaTeX Font Warning: Font shape `LY1/cmr/m/n' undefined 
      (Font)              using `LY1/ptm/m/n' instead on input line 105.
 LaTeX Font Warning: Font shape `LY1/cmr/bx/n' undefined
      (Font)              using `LY1/cmr/m/n' instead on input line 10.
  • 1
    texnansi is 20 years old and should not be used anymore. Use T1 encoding as suggested by Ralf. And load the babel package to activate the german hyphenation, it doesn't work only with the ngerman option. – Ulrike Fischer Jan 9 at 13:24
  • the German hyphenation provided by texlive and miktex is for T1 encoding not texnansi (LY1). – David Carlisle Jan 9 at 14:05
1

The best way to get proper hyphenation and full font support is to use T1 font encoding instead of LY1, which you implicitly use via texnansi:

\documentclass[a4paper, 10pt, sectionprefix, ngerman]{scrbook}
\usepackage[T1]{fontenc}
\pagestyle{empty}
\usepackage{multicol}
\begin{document}
\textbf{bold text here} \\
normal text here
\begin{multicols}{4}
überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur überlange Überholspur über Überlandfahrt überlange Überholspur
\end{multicols}
\end{document}

Note that I have also removed your custom font, since I do not have it. If that is only available in LY1 encoding, you can use

\newcommand{\fancyfont}{\fontfamily{augie}\fontencoding{LY1}\selectfont}

together with otherwise using T1 encoding.

BTW, it might make sense to use lmodern.sty when using T1 encoding. And as Ulrike mentioned in the comments, you should also load babel.sty with the ngerman option.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.