0

Is there any way to make section-wise references in the beamer similar to the case of chapter-wise references in the thesis?

  • You might be interested in the approaches presented in the comments and answers to How do I add a separate bibtex bibliography in beamer to each lecture? – leandriis Jan 11 '20 at 9:52
  • I have seen this, but it is not helping me. I want more than 1 frame at different places in a single presentation. – Bableen Kaur Jan 11 '20 at 9:54
  • With multiple \printbibliography[section=<nr>] commands with <nr> being the number of the corresponding ref section, you can get multiple frames with bibliographies for individual sections. – leandriis Jan 11 '20 at 10:16
0

With \newrefsection to separate the sections from each other and multiple \printbibliography[section=...] commands:

enter image description here

\documentclass{beamer}
\usepackage[style=authoryear]{biblatex}
\addbibresource{biblatex-examples.bib}
\begin{document}


\section{first} \newrefsection
\begin{frame}{first frame of section 1}
Whatever text in the first section
\cite{westfahl:space}
\end{frame}

\begin{frame}{Bibliography of section 1}
\printbibliography[section=1]
\end{frame}

\section{second} \newrefsection
\begin{frame}{first frame of section 2}
Whatever text in the first section
\cite{aksin}
\cite{doody}
\end{frame}

\begin{frame}{Bibliography of section 2}
\printbibliography[section=2]
\end{frame}
\end{document}
  • Can I also do this using 2 different bib files? bib file per section? – Bableen Kaur Jan 11 '20 at 12:47
  • So, I have incorporated your code with the one I need. It is successfully running. I have used the theme of Warsaw. And in that theme, all section headings show up at the top. After including your code, Bibliography is also showing as a heading at the top(multiple times). Is there any way to remove it from showing up at the top? The rest is fine. – Bableen Kaur Jan 11 '20 at 13:45
  • As the answers to How to delete the word 'References' from the navigation bar in Beamer? suggest, adding the heading=none option to \printbibliography command helps. – leandriis Jan 11 '20 at 13:53
  • 1
    It works. Happy now. – Bableen Kaur Jan 11 '20 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.