I build my own .bib file and I use the IEEEtran document class. For bibliography style I'm using:


The IEEEtran bibliography style generates numeric citation call-outs -- [1], [2], etc.

However, I want to cite some references using the "FirstAuthor et al." format. For example,

In [20] Jones et al. studied ...


some phrases Jones et al.[20] studied ... "

How can I do that?

  • 1
    Welcome to TeX SX! If you use biblatex-ieee you can do that with the key [maxcitenames=1].
    – Bernard
    Jan 17, 2020 at 23:32
  • @Bernard, Thanks for your welcome, I use texstudio and miktex. I downloaded IEEEtran.bst file and its related files that were in its package from IEEE website and copied it to the directory. Can you please explain more?
    – Ben25
    Jan 17, 2020 at 23:36
  • biblatex-ieee is the version of the ieee bibliography styles for biblatex, which uses a slightly different syntax, but is easier to customise if necessary (it uses a latex-like syntax) and accepts utf8 encoding if the bibliography engine is biber in the place of bibtex.
    – Bernard
    Jan 17, 2020 at 23:46
  • Is it important that the "et al." part be typeset in italics? Please advise.
    – Mico
    Jan 18, 2020 at 1:00
  • @Mico, Yes, it is needed to be italic.
    – Ben25
    Jan 18, 2020 at 1:05

2 Answers 2


If you can switch from the IEEEtran to the IEEEtranN bibliography style (the N in IEEEtranN stands for natbib), you can make use of natbib's \citeauthor and \citet macros to generate citation call-outs in the desired format.

Addendum to address the OP's requirement that the string "et al." must be typeset in italics:

I suggest you proceed as follows to achieve this objective:

  • Find the file IEEEtranN.bst in your TeX distribution. Make a copy of this file and call the copy, say, IEEEtranN-ital.bst. (Do not edit an original file of the TeX distribution directly.)

  • Open the file IEEEtranN-ital.bst in a text editor. The program you use to edit your tex files will do fine.

  • In the file IEEEtranN-ital.bst, find the following line (l. 201 in my copy of the file):

    FUNCTION {bbl.etal}{ "et~al." }

    Change it to

    FUNCTION {bbl.etal}{ "\textit{et~al.}" }
  • Save the file IEEEtranN-ital.bst, either in the directory that contains your main tex file or in a directory that's searched by BibTeX. If you select the latter option, be sure to update the filename database of your TeX distribution suitably.

  • In your main tex file, change the instruction




    and run a full recompile cycle: LaTeX, BibTeX, and LaTeX twice more. Then, start using the \citeauthor and \citet instruction as and where needed. (I assume that, so far, your document contains only \cite instructions. Please advise if this is not the case.)

The following MWE (minimum working example) loads the hyperref package purely to highlight what's generated by \cite, \citeauthor, and \citet.

enter image description here


  author  = "Dorothy Jones and Daniela Smith and Dinah Webster",
  title   = "Thoughts",
  year    = 3001,

\usepackage[numbers]{natbib} % 'natbib' is a citation management package

\usepackage[colorlinks,allcolors=blue]{hyperref} % optional

\cite{jones} % standard numeric-style citation call-out

In \cite{jones}, \citeauthor{jones} studied \dots

\dots\ some phrases \citet{jones} studied \dots % author-number citation call-out

  • 1
    Thanks for your complete answer. How can I switch to "IEEEtranN" ? Since I am new in LaTeX, I download "IEEEtran" package from IEEE that contains several files and I copied them in the .tex file directory but within my searches for "IEEEtranN" jus an html window can be seen that have too long codes. How can I handle that? Do I replace the new file with several files that I previously copied to directory?
    – Ben25
    Jan 18, 2020 at 1:03
  • Can you change the instruction \bibliographystyle{IEEEtran} to \bibliographystyle{IEEEtranN}? (After changing the argument of \bibliographystyle, it's necessary to run a full recompile cycle: LaTeX, BibTeX, and LaTeX twice more.) The file IEEEtranN.bst should be included in any (normal) group of LaTeX and BibTeX files distributed by the IEEE.
    – Mico
    Jan 18, 2020 at 1:06
  • You're right. Unfortunately I face multiple similar errors of "bad box"
    – Ben25
    Jan 18, 2020 at 1:22
  • I checked my code again and it has no bad box fault but by applying the solution, multiple bad box errors appeared. It may be needed to note that in the code, equations are referenced using \eqref{}. How can I fix the problems? Is there any solution for having italic version of et al. ? Errors are: underful\hbox(badness in 4279) in paragraph. there are multiple such errors?
    – Ben25
    Jan 18, 2020 at 1:48
  • @Ben25 - Please see the addendum I posted, about modifying the bib style file to force the string "et al." to be typset in italics. About your other comments: Creating cross-references to equations via \eqref is entirely separate from creating citation call-outs. The underfull\hbox messages are not errors, just warnings. Are these warnings at all related to any \cite instructions? Sadly, my psychic abilities are absolutely worthless; if you tell me that you're getting warning message but don't tell me how these warnings come about, I am unable to diagnose what may be causing them.
    – Mico
    Jan 18, 2020 at 5:01

I had the similar issue with \citet and I have followed the approach suggested by you but, unfortunately et. al is still not in italics. Could you please help me with it.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .