2

I realize this has come up repeatedly before. My use case does not have any explicit driver selection and is as simple as it can possibly be, so none of the prior answers I've found seem applicable, but it still triggers this warning. The input file is:

\documentclass[11pt]{report}
    
\usepackage{hyperref}
    
\begin{document} 
\chapter{Chapter} 
\end{document}

I'm using texlive 2018.20190227-2 as packaged for Debian 10.2 (installed a few days ago). Running pdflatex on the sample above generates the error:

! Package hyperref Error: Wrong DVI mode driver option `ps2pdf', (hyperref)
because pdfTeX or LuaTeX is running in PDF mode.

Complete log is at https://controlc.com/50fc47f0

Running pdflatex on a Debian 9 system with texlive 2016.2017012 installed doesn't suffer this problem. I wondered if hyperref.cfg from the listings-ext package had some bearing on this, but it's identical between the two environments and I'm at a loss. Is there some other way I should be invoking pdflatex, or some environment parameters I can pass in to get around this?

1
  • Welcome to tex.sx. Commented Jan 19, 2020 at 16:13

1 Answer 1

0

Arggh. Answering my own question after delving into some more of the many, many questions about this error on the site: TEXINPUTS was pointing to /usr/share/texlive/texmf-dist// rather than /usr/share/texlive/texmf-dist/tex// and that was apparently enough to pick up some files it shouldn't have, and that weren't present in the older texlive.

4
  • 1
    Why are you setting texinputs here at all? Commented Jan 19, 2020 at 15:54
  • If there's some way to get \input to refer to my own files in other directories without setting TEXINPUTS or hardwiring paths into the document, I'm open to it.
    – Jon
    Commented Jan 20, 2020 at 16:18
  • 2
    The question is not why you are using texinputs at all, but why you are using it to point to a texmf tree - it is searched by kpathsea anyway. Commented Jan 20, 2020 at 16:24
  • I have the same problem. My TEXINPUTS is fine , however that does not work for me. I get the same error. Commented Aug 5, 2021 at 12:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .