0

I just have installed LaTeXiT and it is not working. I get an error message, which says "unexpected error, please see LaTeX > Display last log". I don't know what do to now, though. Here is the text in the 'Display last log'-window:

Source :
\documentclass[10pt]{article}
\usepackage[usenames]{color} %used for font color
\usepackage{amssymb} %maths
\usepackage{amsmath} %maths
\usepackage[utf8]{inputenc} %useful to type directly diacritic characters

\pagestyle{empty} \begin{document}\begin{align*}7
\end{align*}
\end{document}

--------------- processing pdflatex ---------------
#!/bin/sh
export TMPDIR="/var/folders/c5/ny8m65rd0w3_s0_tvw4kh7gr0000gn/T/" 1>/dev/null 2>&1 
export USER="henrilila" 1>/dev/null 2>&1 
export __CF_USER_TEXT_ENCODING="0x1F5:0x0:0x0" 1>/dev/null 2>&1 
export SHELL="/bin/bash" 1>/dev/null 2>&1 
export HOME="/Users/henrilila" 1>/dev/null 2>&1 
export XPC_SERVICE_NAME="com.apple.xpc.launchd.oneshot.0x10000004.LaTeXiT" 1>/dev/null 2>&1 
export XPC_FLAGS="0x0" 1>/dev/null 2>&1 
export COMMAND_MODE="unix2003" 1>/dev/null 2>&1 
export PATH="/sw/usr/local/sbin:/Library/Frameworks/Mono.framework/Versions/Current/Commands:/usr/local/texbin:/usr/local/sbin:/sw/local/bin:/usr/local/bin:/usr/texbin:/sw/sbin:/sw/local/sbin:/sbin:/Library/TeX/texbin:/usr/local/share/dotnet:/usr/bin:/usr/sbin:/sw/usr/bin:/opt/local/bin:/opt/local/sbin:/bin:/sw/usr/sbin:/sw/usr/local/bin:~/.dotnet/tools:/sw/bin" 1>/dev/null 2>&1 
export LOGNAME="henrilila" 1>/dev/null 2>&1 
export SSH_AUTH_SOCK="/private/tmp/com.apple.launchd.HHnLFLy1ep/Listeners" 1>/dev/null 2>&1 
cd /var/folders/c5/ny8m65rd0w3_s0_tvw4kh7gr0000gn/T/LaTeXiT-2.14.4
/usr/local/bin/pdflatex -file-line-error -interaction nonstopmode /var/folders/c5/ny8m65rd0w3_s0_tvw4kh7gr0000gn/T/LaTeXiT-2.14.4/latexit-1.tex 1>|/var/folders/c5/ny8m65rd0w3_s0_tvw4kh7gr0000gn/T/LaTeXiT-2.14.4/latexit-task-stdout.tS2T2hcY.log 2>|/var/folders/c5/ny8m65rd0w3_s0_tvw4kh7gr0000gn/T/LaTeXiT-2.14.4/latexit-task-stderr.xTc7CPXb.log </dev/null

This is pdfTeX, Version 3.14159265-2.6-1.40.20 (MiKTeX 2.9.7050)
entering extended mode
(/var/folders/c5/ny8m65rd0w3_s0_tvw4kh7gr0000gn/T/LaTeXiT-2.14.4/latexit-1.tex
LaTeX2e <2019-10-01> patch level 3

("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
base/article.cls"
Document Class: article 2019/10/25 v1.4k Standard LaTeX document class

("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
base/size10.clo"))
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
graphics/color.sty"
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
graphics-cfg/color.cfg")
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
graphics-def/pdftex.def"))
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
amsfonts/amssymb.sty"
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
amsfonts/amsfonts.sty"))
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
amsmath/amsmath.sty"
For additional information on amsmath, use the `?' option.

("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
amsmath/amstext.sty"
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
amsmath/amsgen.sty"))
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
amsmath/amsbsy.sty")
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
amsmath/amsopn.sty"))
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
base/inputenc.sty")
No file latexit-1.aux.

("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/contex
t/base/mkii/supp-pdf.mkii"
[Loading MPS to PDF converter (version 2006.09.02).]
)
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
amsfonts/umsa.fd")
("/Users/henrilila/Library/Application Support/MiKTeX/texmfs/install/tex/latex/
amsfonts/umsb.fd") [1{/Users/henrilila/Library/Application Support/MiKTeX/texmf
s/data/pdftex/config/pdftex.map}] (latexit-1.aux) )</Users/henrilila/Library/Ap
plication Support/MiKTeX/texmfs/install/fonts/type1/public/amsfonts/cm/cmr10.pf
b>
Output written on latexit-1.pdf (1 page, 8413 bytes).
Transcript written on latexit-1.log.

--------------- bounding box computation ---------------
#!/bin/sh
export TMPDIR="/var/folders/c5/ny8m65rd0w3_s0_tvw4kh7gr0000gn/T/" 1>/dev/null 2>&1 
export USER="henrilila" 1>/dev/null 2>&1 
export __CF_USER_TEXT_ENCODING="0x1F5:0x0:0x0" 1>/dev/null 2>&1 
export SHELL="/bin/bash" 1>/dev/null 2>&1 
export HOME="/Users/henrilila" 1>/dev/null 2>&1 
export XPC_SERVICE_NAME="com.apple.xpc.launchd.oneshot.0x10000004.LaTeXiT" 1>/dev/null 2>&1 
export XPC_FLAGS="0x0" 1>/dev/null 2>&1 
export COMMAND_MODE="unix2003" 1>/dev/null 2>&1 
export PATH="/sw/usr/local/sbin:/Library/Frameworks/Mono.framework/Versions/Current/Commands:/usr/local/texbin:/usr/local/sbin:/sw/local/bin:/usr/local/bin:/usr/texbin:/sw/sbin:/sw/local/sbin:/sbin:/Library/TeX/texbin:/usr/local/share/dotnet:/usr/bin:/usr/sbin:/sw/usr/bin:/opt/local/bin:/opt/local/sbin:/bin:/sw/usr/sbin:/sw/usr/local/bin:~/.dotnet/tools:/sw/bin" 1>/dev/null 2>&1 
export LOGNAME="henrilila" 1>/dev/null 2>&1 
export SSH_AUTH_SOCK="/private/tmp/com.apple.launchd.HHnLFLy1ep/Listeners" 1>/dev/null 2>&1 
cd /var/folders/c5/ny8m65rd0w3_s0_tvw4kh7gr0000gn/T/LaTeXiT-2.14.4
/usr/local/bin/gs-noX11 -sstdout=%stderr -dNOPAUSE -dSAFER -dNOPLATFONTS -sDEVICE=bbox -dBATCH -q /var/folders/c5/ny8m65rd0w3_s0_tvw4kh7gr0000gn/T/LaTeXiT-2.14.4/latexit-1.pdf 1>|/var/folders/c5/ny8m65rd0w3_s0_tvw4kh7gr0000gn/T/LaTeXiT-2.14.4/latexit-task-stdout.KR04n0o4.log 2>|/var/folders/c5/ny8m65rd0w3_s0_tvw4kh7gr0000gn/T/LaTeXiT-2.14.4/latexit-task-stderr.PpKIPGRY.log </dev/null

I'd be happy for any help! Thanks in advance!

  • 2
    Do you have more than oneTeX distribution installed? It appears that LaTeXiT is using a MikTeX distribution and you also have /Library/TeX/texbin on your path which suggests you have a TeX Live distribution installed by the MacTeX installer. – Herb Schulz Jan 19 at 18:54
  • 1
    Assuming you have TeX Live as installed by the MacTeX installer make sure all the appropriate items under the Typesetting tab in LaTeXiT->Preferences have the correct paths set. E.g., /Library/TeX/texbin/pdflatex for pdflatex. – Herb Schulz Jan 19 at 22:07
1

I solved the problem, and this is how: I opened the MikTeX Console application and updates by clicking "Update now" on the Overview page. After doing that, it works now :) (MikTeX does not automatically update, so every now and then you should manually search for updates by opening the MikTeX Console application.) Anyways, if this doesn't solve your problem, it's probably because LaTeXiT is not using the appropriate documents, as @Herb Schulz suggested.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.