2

This question is similar to this one: TeXnicCenter & Adobe Reader DC.

How to configure TeXnicCenter to work with Adobe Reader DC?

I have used the solution(s) listed on that linked question many times in the past. However, the solutions no longer work. This may be due to a recent upgrade to Windows 10, or because the Adobe Reader version is wrong.

What I have tried:

  • Checking the location of AcroRd32.exe (it is still in the same folder)
  • Changing the server to acroviewR19. (If I open AcroRd32.exe, the version at the top is 19.021.20061. Before the OS upgrade, I was successfully using acroviewR19 as the server.)
  • Changing the server to acroviewR20. This opens Adobe Acrobat Reader DC (if it is not already open) while TeXnicCenter hangs for about 20 seconds before showing the same error message.
  • Changing all 5 instances of %bm to %tm on the viewer tab of Profiles based on the suggestion here (even though that related to BibTeX, not the output viewer).
  • Setting packages to be automatically installed on-the-fly (as suggested here; this was the setting I had previously when it worked). (i.e. MiKTeX Console > Settings > General tab > "Always install missing packages on-the-fly").

Regardless of what I do, I get the same error message as on the other post:

enter image description here

If I use acroviewR19, I sometimes see this error message first before getting the one above:

There was an error opening this document. This file cannot be found.

I've applied the latest OS updates and restarted my computer.

  • 1
    I was previously using Windows 7, where acroviewR19 worked. – Earlien Jan 23 at 0:47
  • 1
    When I compile my document, it compiles without errors or warnings (LaTeX and BibTeX). But no PDF or related Tex files are produced. – Earlien Jan 23 at 2:16
  • I have (in win10, not in texniccenter but in winedt) currently AcroviewR19 as server and it still works. – Ulrike Fischer Jan 23 at 8:15
  • Could you post a screenshoot of the settings? I just did a fresh install and cannot make the pdf open Thanks a lot – Rodolfo Feb 6 at 12:36
  • @Rodolfo The screenshot is the same as in the answer to the linked question: tex.stackexchange.com/questions/250472/…, with the only change being acroviewR19 as the server rather than acroviewR15. – Earlien Feb 8 at 0:31
1

I had the same issue on Windows 10 after the latest updates on 12th Feb 2020. Acrobat reader had silently upgraded to release 20. So just replace the server string in the DDE command with "acroviewR20". You find it in Output --> Profiles --> Viewer.

|improve this answer|||||
  • As I said in the question, I tried this and it did not work for me. My version of Adobe hadn’t changed, so acroviewR19 was still correct. Glad it solved your issue though. – Earlien Feb 13 at 21:56
0

I ended up doing a completely fresh installation (TeXnicCenter and MiKTeX). LaTeX now successfully compiles and builds the PDF output.

Before I did the reinstall, I took screen captures of the output profile settings. It worked with both Adobe Acrobat acroviewA11 (default) and Adobe Reader acroviewR19 (which is now identical to the old installation).

The forced upgrade to Windows 10 must have broken something. But I don't know what. If you have the same problem, my advice is to bite the bullet and reinstall.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.