0

In beamer presentation I have a slide like this

\begin{frame}
  \begin{itemize}[<+->]
    \item My first point   \fullscreenimage<+>{Image1.png}
    \item My second point  \fullscreenimage<+>{Image2.png}
  \end{itemize}
\end{frame}

here I would like to uncover each item at a time showing a full screen image after each new item. So the sequence should look like this:

<1>
  +---------------------------+
  |  * My first point         |
  |                           |
  |                           |
  |                       3/6 |
  +---------------------------+
<2>
  +---------------------------+
  |///////////////////////////|
  |///////// Image 1 /////////|
  |///////////////////////////|
  |///////////////////////////|
  +---------------------------+
<3>
  +---------------------------+
  |  * My first point         |
  |                           |
  |  * My second point        |
  |                       3/6 |
  +---------------------------+
<4>
  +---------------------------+
  |///////////////////////////|
  |///////// Image 2 /////////|
  |///////////////////////////|
  |///////////////////////////|
  +---------------------------+

My problem is, that after showing the full screen image, the beamer continues to output stuff from the page, like grayed out items yet to be uncovered and the footer of the page, like this:

<2>
  +---------------------------+
  |///////////////////////////|
  |///////// Image 1 /////////|
  |////grayed out items///////|
  |////////////////////// 3/6 |
  +---------------------------+

I know, that

\begin[plain]{frame}

partially solves the page footer problem. But it removes footer for all slides, not only for the full screen slides.

What I'm looking for is some command, that would instruct beamer to stop any further output to the page (or make is 100% transparent):

\begin{frame}
  \begin{itemize}[<+->]
    \item My first point
      \only<+>{
        \fullscreenimage{Image1.png}
        \STOPrendering
      }
    \item My second point
      \only<+>{
        \fullscreenimage{Image2.png}
        \STOPrendering
      }
  \end{itemize}
\end{frame}

My questions are:

  • How to hide all further text for the current slide?
  • How to add overlay specification to the [plain] frame option?
  • How to change itemize overlay uncover transparency for the current slide?

1 Answer 1

1

A solution using textpos:

\documentclass[11pt]{beamer}
\usepackage[absolute,overlay]{textpos}
\TPGrid{1}{1}
\begin{document}
\begin{frame}
  \begin{itemize}
    \item<1,3> My first point   
    \item<3> My second point  
  \end{itemize}
\begin{textblock}{1}(0,0)
\includegraphics<2>[width=\textwidth]{example-image-a}
\includegraphics<4>[width=\textwidth]{example-image-b}
\end{textblock}
\end{frame}
\end{document}
3
  • textpos package works great indeed, besides one minor flow: each time a textblock get rendered it introduces negative vertical shift, like "\vspace{-1mm}". Any idea how to stop this from happening? Thank you! Commented Jan 23, 2020 at 17:53
  • I'm sorry, but with the solution above I don't get the vertical shift that you refer. Try to open another question with a MWE with the problem. Could it be related with the size of your images? Could it be a spurious space due to newline in your code?
    – vi pa
    Commented Jan 23, 2020 at 19:38
  • Done, please see tex.stackexchange.com/questions/525453/… Commented Jan 24, 2020 at 7:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .