2

I have install the package for a font similar to Arial

\usepackage{helvet}
\renewcommand{\familydefault}{\sfdefault} 

However, in the table of contents the name of my sections don't show in this font but the normal latex font. I have put some subsections in my text, in one of the section, and the title of the subsections in the table of contents appear in the font similar to Arial.

  • 2
    Could you provide better minimal working example (MWE) that illustrates your problem? Using the same code as you I get a working document. – Henrik Hansen Apr 19 '12 at 12:40
  • 2
    Not an answer to your question, but a general observation: You note in the title of your question that you wish to use Arial, but in example code you provide you load Helvetica. (Arial is a "descendant", to put it politely, of Helvetica.) If you really need Arial, you could load the uarial package instead of the helvet package. – Mico Apr 19 '12 at 12:56
4

I don't see the problem. Compiling this MWE:

\documentclass{report}
\usepackage{helvet}
\renewcommand{\familydefault}{\sfdefault} 
\usepackage{lipsum}

\begin{document}
\tableofcontents
\chapter{Introduction}
\section{The social interaction}
\subsection{Homophily}
\lipsum[1]
\subsection{Social distance}
\lipsum[2]
\end{document}

I get:

enter image description here

Notice that my TeXLive is regularly updated.

  • It still doesn't work. Is it because I include my section: \include{section} in my main document? – Lyy Apr 19 '12 at 13:39
  • @Lyy: my answer is no. I've just tried to include the whole part of my code starting from \section{The social interaction} to \lipsum[2] in a file called section.tex. Then I used \include{section} after the declaration of \chapter{Introduction}, but it still works. – Claudio Fiandrino Apr 19 '12 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.