0

I'm using Zotero (V.5.0.81) and BetterBibtex (V.5.2.7) in order to export my bibliography to a .bib file. When I do that, my pagetotal field for @books doesn't appear in my .bib.

It works well on another computer, therefore I don't understand why Nb of pages Zotero field isn't automatically exported.

EDIT :

I want to have the pagetotal field in my .bib after my exportation. Therefore, the total number of pages for @books. On my another computer my Zotero field Nb of pages is automaticaly converted in a .bib Pagestotal. It is not the case now.

There, an example of the same Zotero @book reference converted on my two computers in a .bib. The only difference between my two configurations is the version of BetterBibtex (V.5.1.58 and V.5.2.7) :

Old .bib :

@book{bueltzingsloewenHecatombeFousFamine2007,
  langid = {french},
  location = {{Paris}},
  title = {L'h\'ecatombe des fous: la famine dans les h\^opitaux psychiatriques fran{\c c}ais sous l'Occupation},
  shorttitle = {L'h\'ecatombe des fous},
  pagetotal = {512},
  publisher = {{Aubier}},
  date = {2007},
  keywords = {History,France,Psychiatric hospitals,20th century,Atrocities,German occupation; 1940-1945,Killing of the mentally ill,Victims of famine,World War; 1939-1945,ag},
  author = {von Bueltzingsloewen, Isabelle}

}

Now :

@book{bueltzingsloewenHecatombeFousFamine2007,
  title = {{L'h{\'e}catombe des fous: la famine dans les h{\^o}pitaux psychiatriques fran{\c c}ais sous l'Occupation}},
  shorttitle = {{L'h{\'e}catombe des fous}},
  author = {von Bueltzingsloewen, Isabelle},
  year = {2007},
  publisher = {{Aubier}},
  address = {{Paris}},
  groups = {Approche g{\'e}n{\'e}rale,Asiles},
  keywords = {20th century,ag,Atrocities,France,German occupation; 1940-1945,History,Killing of the mentally ill,Psychiatric hospitals,Victims of famine,World War; 1939-1945},
  language = {fr},
  lccn = {RC450.F7 B84 2007},
  timestamp = {2019-06-09T11:32:56Z}
}

Thank you for your help.

ANSWER :

The problem was that I was exporting with BetterBibtex which doesn't support pagestotal field. Exporting with BetterBibLatex solves the problem.

4
  • 1
    by pages do you mean number of pages? Zotero doesn't have a pages field for books.
    – adam.smith
    Commented Jan 26, 2020 at 2:28
  • While biblatex's standard data model accepts a pages field for @book entries it isn't used all that much. pages usually refers to the range of pages that the work takes up in a larger work (for example the page range of an @article in its journal, or of an @incollection chapter), for @books that usually doesn't apply. If one wants to refer to a specific page (range) of a book that is usually done in the citation. Do you really need a pages field here? ...
    – moewe
    Commented Jan 26, 2020 at 8:11
  • ... I would have mentioned that Better BibTeX lets you configure the .bib file export of your Zotero database quite extensively, but if Zotero simply doesn't have a pages field equivalent for @books, then that might not be an option. As adam.smith hints at, there is a field for the total number of pages in biblatex: pagetotal (not sure about Zotero support for that field).
    – moewe
    Commented Jan 26, 2020 at 8:12
  • Thank you for your Help. By pages, I Mean the total number of pages, the .bib pagetotal field. Usually, on my last computer the Zotero field Nb of pages of @books was automaticaly converted to pagetotal field.
    – Tixma
    Commented Jan 27, 2020 at 8:53

1 Answer 1

2

If you export as biblatex rather than bibtex, the pagetotal field will show up.

5
  • Thank you for your help. But my problem is that I want the total number of pages of @books ( Nb of pages field in Zotero converted in Pagetotal field in biblatex). Sorry for the misunderstanding, I edited my question.
    – Tixma
    Commented Jan 27, 2020 at 8:57
  • I've edited my answer to reflect this.
    – retorquere
    Commented Jan 27, 2020 at 21:22
  • Thank you again, it works well ! But it's strange I'm pretty sure that Zotero has a field for book entries : # of pages as you can see in this documentation : Zotero doc. And this field was converted with my last version of BBT. Sorry to bother you and thank you again.
    – Tixma
    Commented Jan 28, 2020 at 8:53
  • You are correct. If you open an issue on the BBT GH page, I'll add it.
    – retorquere
    Commented Jan 28, 2020 at 11:40
  • I'll do it, thank you very much.
    – Tixma
    Commented Jan 28, 2020 at 11:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .