0

I am using LatexTools in Sublime 3, Windows 10, Miktex 2.9. When I call the command Build with: Latex - Traditional, it automatically revoke -texify and everything is working OK.

But what I hope is to add the parameter -cp to texify, which has the effect to automatically delete all the aux files after compiling. (The following syntax work perfectly in Command Prompt:

textify --pdf -cp myfile.tex

Following the suggestion in this post, I have tried to edit LaTeXTools.sublime-settings as follows:

"builder_settings" : {

    // General settings:
    // See README or third-party documentation

    // (built-ins): true shows the log of each command in the output panel
    "display_log" : false,

    "options": ["-cp"],

    // Platform-specific settings:
    "osx" : {
        // See README or third-party documentation
    },

    "windows" : {
        // See README or third-party documentation
    },

    "linux" : {
        // See README or third-party documentation
    }
},

But I got no success. The error notification is Could not read log file myfile.log.

Please kindly instruct me a solution for that issue. Many thanks.

2
  • 2
    The -c option deletes the logfile. Therefore LaTeXTools can't find it and complains about this. You may also think about whether the cleanup shortcut C-l, backspace might be sufficient for you.
    – r-stein
    Commented Jan 28, 2020 at 18:00
  • Thanks. I got a solution. Edit LaTeXTools.sublime-settings with: "command": ["texify", "-cp", "--engine=%E"], . It successfully creates PDF file. But the notification Could not find Log still shows. Any one might help to suggest any better way? Thanks. Commented Jan 29, 2020 at 1:08

0

You must log in to answer this question.

Browse other questions tagged .