3

After updating my MiKTeX-Installation (dated 2020-01-29) I am unable to compile my LaTeX-files.

Here is my MWE:

\documentclass{article}
\usepackage{hyperref}
\begin{document}
\href{www.google.com}{Google}
\end{document}

If i try to compile this using pdflatex Test.tex I get the following output on the command line:

...
...
("C:\Program Files\MiKTeX2.9\tex/generic/intcalc\intcalc.sty")
("C:\Program Files\MiKTeX2.9\tex/generic/etexcmds\etexcmds.sty")

After a while the MiKTeX Package Installation dialog box pops up with the following message:

The required file
  tex/latex/00miktex/hyperref.cfg
is missing. It is part of the following package:
  miktex-latex

After clicking Install the output on the command line continues with

======================================================================
starting package maintenance...
installation directory: "C:\Program Files\MiKTeX2.9"
package repository: C:/Installation/LaTeX/MiKTeX/Repository
package repository digest: 498d1111335cf2fa3fddb12ad2aee195
going to install 4 file(s) (1 package(s))
extracting files from miktex-latex.tar.lzma...
======================================================================

Sorry, but pdflatex did not succeed.

The log file hopefully contains the information to get MiKTeX going again:

  C:\Users\xxxx\AppData\Local\MiKTeX\2.9\miktex\log\pdflatex.log

The log-files contains the following:

INFO  pdflatex - starting with command line: pdflatex Test.tex
WARN  pdflatex - running with administrator privileges
INFO  pdflatex - allowing known shell commands
INFO  pdflatex - enabling input (output) from (to) processes
INFO  pdflatex - installing package miktex-latex triggered by tex/latex/00miktex\hyperref.cfg
INFO  pdflatex - mpm: starting package maintenance...
INFO  pdflatex - mpm: installation directory: "C:\Program Files\MiKTeX2.9"
INFO  pdflatex - mpm: package repository: C:/Installation/LaTeX/MiKTeX/Repository
INFO  pdflatex - mpm: package repository digest: 498d1111335cf2fa3fddb12ad2aee195
INFO  pdflatex - mpm: going to install 4 file(s) (1 package(s))
INFO  pdflatex - mpm: extracting files from miktex-latex.tar.lzma...
FATAL pdflatex - The installed file does not exist.
FATAL pdflatex - Info: fileName="C:\Program Files\MiKTeX2.9\tex/latex/00miktex\hyperref.cfg"
FATAL pdflatex - Source: Libraries\MiKTeX\Core\Session\findfile.cpp
FATAL pdflatex - Line: 59
INFO  pdflatex - finishing with exit code 1

Interestingly the repository file miktex-latex.tar.lzma contains only 3 files, namely:

texmf/tex/latex/00miktex/latex.ini
texmf/tex/latex/00miktex/pdflatex.ini
texmf/tpm/packages/miktex-latex.tpm

In an older repository version (2020-01-21) which I still have there are 4 files in miktex-latex.tar.lzma:

texmf/tex/latex/00miktex/hyperref.cfg
texmf/tex/latex/00miktex/latex.ini
texmf/tex/latex/00miktex/pdflatex.ini
texmf/tpm/packages/miktex-latex.tpm

So obviously MiKTeX tries to install / update a file hyperref.cfg which supposedly should be in miktex-latex.tar.lzma. But since 2020-01-22 it isn't there anymore.

I also tried with a complete new clean install of MiKTeX but with the same result.

BTW, using the repository dated 2020-01-29 makes it necessary to apply Ulrike's solution from File hycolor.sty not found

  • Did you update miktex both in miktex user mode and miktex admin mode. Depending om how you uninstalled the user mode miktex part may have survived and thus is messing up your miktex – daleif Jan 30 at 19:09
  • When updating, both user and admin mode tell me: "There are currently no updates available". – BaWue Jan 30 at 19:16
  • Did you also reload the repository list or whatever it is called, it is not reloaded/updated automatically. Also did you try a different mirror to update from, you might have hit a slow one – daleif Jan 30 at 19:19
  • Refering to the "repository list" you mean the file files.csv.lzma? – BaWue Jan 30 at 19:25
  • This is also up to date (2020-01-29). – BaWue Jan 30 at 19:25
4

The problem can be solved by updating the package database using Tasks / Update package database and Tasks / Refresh file name database.

Credits for the solution go to "daleif". Thanks.

  • 2
    This solution worked for me, but I had to do it using both user-mode and admin-mode MikTeX console (in this order). – Cedric Feb 3 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.