0

I have been working on a large document form some time now already, and I recently noticed that some of the \max and \min operators I used in math-mode and equation environments are being compiled into musical notes and inifinity-like symbols. Example:

enter image description here

The weird thing is that I first of all did not change the particular lines, they used to be compiled correctly and this just happened all of a sudden, after which I noticed it. Secondly, it only does this for some of the \min and \max operators involved, not for all.

These are the packages I use:

\documentclass[whitelogo,oneside]{tudelft-report}
\usepackage{changes}

%Citation
\usepackage{natbib}
\usepackage{hyperref}
\setcitestyle{authoryear,colon,round}

%Other packages
\usepackage{geometry} 
\usepackage{url}
\usepackage[utf8]{inputenc}
\usepackage{graphicx}
\usepackage{etoolbox}
\usepackage{tabu}
\usepackage{float}
\usepackage{eurosym}
\usepackage{textcomp,gensymb}
\usepackage{booktabs}
\usepackage{multirow}
\usepackage{array}
\usepackage[justification=centering]{caption}
\usepackage{subcaption}
\usepackage{amsmath}
\usepackage{mathtools}
\usepackage{array, booktabs, makecell}
\usepackage{longtable}
\usepackage{tikz}
\usepackage{amssymb}
\usepackage{bm}
\usepackage{amsfonts}
\usepackage{comment}
\usepackage{colortbl}
\usepackage{arydshln}
\usepackage{wrapfig}
\usepackage{footmisc}
\usepackage{tablefootnote}

\interfootnotelinepenalty=10000 %% Completely prevent breaking of footnotes

Code of the example equation:

\begin{equation}
    \begin{aligned}
         & \min \zeta \\
         & \text{subject to:}\\
         & \left |x_i^{m} - x_i^k  \right | \leq \zeta, \forall i, k\\
         & x_i^{\min} \leq x_i^k \leq x_i^{\max}, \forall i, k \\
    \end{aligned}
\end{equation}

Is someone else familiar with this problem, and knowing how to fix?

Thanks a lot!

K

  • 3
    Welcome! I'm sorry, but this surely depends on some weird setting you or the template you're using are doing. Without a minimal example of code reproducing the issue it's essentially impossible to help. – egreg Feb 4 at 10:52
  • Thanks, edited! – kyle.v Feb 4 at 11:11
  • 1
    I downloaded the class from github.com/praseodym/tudelft-report-latex/blob/master/… and ran your example getting no musical symbols, but the expected “max” and “min”. – egreg Feb 4 at 11:20
  • please don't post disconnected fragments post a small complete document that shows the error (deleting any packages that are not required to show the error) – David Carlisle Feb 4 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.