0

I started to learn LaTeX in the hope to gain speed and accuracy with references in my philosophical articles. But after five days struggling I am still stuck. Of course I am trying to do complex things without knowing all the basics, but hey! I am an engineer, so I don't do manuals from beginning to the end :-)

\documentclass[a4paper,12pt,dutch]{article}
%\usepackage[notes]{biblatex-chicago}
\usepackage[style=chicago-authordate,babel=other, backend=biber]{biblatex}
\usepackage[dutch]{babel}
\addbibresource{./myreferences.bib}

When I compile like this the bibliography works fine and uses Dutch, but the footnotes are (of course) Chicago style authordate. The footnote that uses the Dutch translation of 'Translated by' works perfect.

What is the name of the chicagostyle notes? I tried chicago-notes but then I received warnings:

'babel/polyglossia' detected but 'csquotes' missing.

Bibliography string 'cbytranslator' undefined(biblatex) at entry 'Foo'

Using the other \usepackage (line 2) and commenting out the other (line 3), I get the same warnings, and in this case in the footnote the cbytranslator is not resolved. (I did even reinstall csquotes from CTAN).

cbytranslator should give me the dutch translation of 'Translated by'. Can someone give me a hint or a solution?? Thank you very much!

Edited: Maybe my myreference.bib entry is incorrect?

@mvbook{Foo,
    author = {Plato},
    title = {De Staat},
    date = {2009},
    translator = {Xavier De Win},
    titleaddon = {Alcibiades I – De Staat – De Staatsman – Critias},
    volumes = {3},
    publisher = {Pelckmans},
    location = {Kapellen},
}

Here is a snippet:

\documentclass[a4paper,12pt,dutch]{article}

\usepackage[notes]{biblatex-chicago}
\usepackage{csquotes}

%\usepackage[style=chicago-notes,babel=dutch, backend=biber]{biblatex}

\usepackage[dutch]{babel}

\addbibresource{./myreferences.bib}

\begin{document}
    
    \null\vfill% just for the example
    
    This is some text.\footcite{Foo} 

\printbibliography    
\end{document}
5
  • As always on the site you are much more likely to get help if you provide a full minimal example instead of the sniplet above – daleif Feb 4 '20 at 16:32
  • I found the problem of the missing csquotes: I put it in /usr/local/share/texmf , later I tried /usr/share/texmf , but it finally worked when I put it in /home/<my_name>/texmf . I really don't understand why something like that should be stored in my home directory, but alas! – Zuidinga Feb 4 '20 at 16:32
  • 1
    Never ever update your LaTeX installation manually! that is why we have package managers both on the latex side and on the Linux side. – daleif Feb 4 '20 at 16:37
  • Sorry guys, I think I am waisting my time by trying. Maybe Texstudio didn't install everything correctly, maybe the dutch language is not fully supported. In the bibliography it works with dutch texts, but not in the citations in the footnote. I will declare this question as closed, as it has no point in researching this any further. I am not a bibtex programmer. See you! – Zuidinga Feb 4 '20 at 18:54
  • Welcome!It is not TeXstudio which installs packages (it is only a TeX-dedicated editor), but the package manager of your distribution. Did you think of adding the option [autocite=footnote] the default is inline)? – Bernard Feb 4 '20 at 19:21
1

The warning

'babel/polyglossia' detected but 'csquotes' missing.

is unrelated to the main issue at hand here, but it is still a good idea to load csquotes with biblatex. (As discussed in the comments you should not have to install the package manually. Install packages through your distribution - tlmgr or MikTeX Console.)


The main issue here is that biblatex-chicago has no Dutch localisation. Standard biblatex has a Dutch localisation, so most things still work fine, but some biblatex-chicago-specific strings may not be available. One of these strings is cbytranslator. That's why you get the warning

Package biblatex Warning: Bibliography string 'cbytranslator' undefined
(biblatex)                at entry 'destaat' on input line 25.

If you want full support for all translations needed by biblatex-chicago, you can get one of its .lbx files (for example from CTAN: https://ctan.org/tex-archive/macros/latex/contrib/biblatex-contrib/biblatex-chicago/latex/lbx) and translate it into Dutch. If you complete the file, you may want to contact the author of biblatex-chicago and ask him to include it into his package.

If you only want this document to come out OK, you can define the required strings (those that biblatex warns about) on the fly.

First you need to declare the missing string with

\NewBibliographyString{<bibstring>}

and then you need to give its translation in

\DefineBibliographyStrings{dutch}{
  <bibstring> = {<Dutch translation>},
}

The full definition of the cbytranslator bibstring is a bit more tricky than usual, so I included a more straightforward example as well. See also biblatex-chicago: Change translator and editor description in the bibliography.

\documentclass[a4paper,12pt,dutch]{article}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[notes]{biblatex-chicago}

\NewBibliographyString{cbyeditor}
\NewBibliographyString{cbytranslator}
\makeatletter
\DefineBibliographyStrings{dutch}{
  cbyeditor     = {geredigeerd door},
  cbytranslator = {\lbx@fromlang\ vertaald door},
}
\makeatother

\begin{filecontents}{\jobname.bib}
@mvbook{destaat,
  author     = {Plato},
  title      = {De Staat},
  date       = {2009},
  translator = {Xavier De Win},
  titleaddon = {Alcibiades I – De Staat – De Staatsman – Critias},
  volumes    = {3},
  publisher  = {Pelckmans},
  location   = {Kapellen},
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
  \null\vfill% just for the example

  This is some text.\autocite{destaat} 

  \printbibliography  
\end{document}

Note that the issue mainly occurs in the citations, since biblatex-chicago defines new bibstrings for citations, but uses existing strings for the bibliography.

Plato, De Staat, Alcibiades I – De Staat – De Staatsman – Critias, vertaald door Xavier De Win, 3 delen (Kapellen: Pelckmans, 2009).


In general it is recommended to load the style of biblatex-chicago via the wrapper package, i.e.

\usepackage[notes]{biblatex-chicago}

or

\usepackage[authordate]{biblatex-chicago}

and not via biblatex directly (as in \usepackage[style=chicago-authordate,babel=other, backend=biber]{biblatex}), since the wrapper package automatically sets all required options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.