2

This question could be split in two parts:

  • Modifying the TOC to display subsubsections
  • Formatting the unnumbered chapters to have the same font used in numbered ones, This is adding small caps

The first part is quite easy, two lines must be added to the preamble

\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}

For the second part I found an answer here Capitalize chapter* in toc with classicthesis

The problem is that I cannot make this solutions work together, the output I get is a capitalized numberless chapter and subsubsections displayed in the TOC but those are numberless too.

I tried switching the line \newenvironment{unnumbered}{\setcounter{secnumdepth}{-1}}{\setcounter{secnumdepth}{2}} to \newenvironment{unnumbered}{\setcounter{secnumdepth}{-1}}{\setcounter{secnumdepth}{3}} but was very unnefective.

Also if you have any suggestion on how to make the numberless chapter text in the TOC aligned with the first letter of the numbered chapters would be great!

Here's a MWE

\documentclass[oneside,letterpaper]{scrbook}
\usepackage{classicthesis}
\usepackage{lipsum} % for dummy text
\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}
\newenvironment{unnumbered}%
{\setcounter{secnumdepth}{-1}}
{\setcounter{secnumdepth}{2}}
\begin{document}
    \tableofcontents
    \chapter{A  regular chapter}
    \lipsum
    \section{section}
    \subsection{subsection}
    \subsubsection{subsubsection}
    \begin{unnumbered}
        \chapter{An unnumbered chapter}
        \lipsum
    \end{unnumbered}
\end{document}

thanks in advance!

1

First of all: package classicthesis loads packages titlesec and tocloft. It is not recommended to use these packages with a KOMA-Script class. You will get a bunch of warnings and KOMA-Script options will not work as expected. So maybe you have to replace scrbook by the standard class book.

%\documentclass[oneside,letterpaper]{scrbook}
\documentclass[oneside,letterpaper]{book}

\usepackage{classicthesis}
\usepackage{blindtext}% only for dummy text
\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}
\newenvironment{unnumbered}%
{\setcounter{secnumdepth}{-1}}
{\setcounter{secnumdepth}{3}}

\renewcommand{\cftchapfont}{\spacedlowsmallcaps}% spaced small caps for all chapter entries

\makeatletter
% warning: redefinition of an undocumented internal command -> could break in the future
\def\ttl@addcontentsline#1#2{%
  \addcontentsline{toc}{#1}{\ifttl@toclabel\ttl@a\else\numberline{}\fi#2}% indent unnumbered ToC entries too
  \nobreak}
\makeatother

\begin{document}
\tableofcontents
\blinddocument
\begin{unnumbered}
  \blinddocument
\end{unnumbered}
\blinddocument
\end{document}

enter image description here

| improve this answer | |
  • Thank you for your answer, this works great unless you are using the well known classicthesis template by miede at least for me I´ll try to figure out what´s going on there but it works in every document I´ve tried apart from that – Paul Lara Feb 14 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.