61

The IEEEtran document class is hiding page numbers from my document! Is it possible to force page numbers to appear in the document?

EDIT: Sorry I should have mentioned that I am using conference mode!

4
  • 4
    Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. A simple test I did shows the page numbers.
    – egreg
    Apr 20, 2012 at 19:46
  • 3
    If you used the conference mode, automatically headings and page numbers are not displayed. Apr 21, 2012 at 6:55
  • Where do you want the page numbers located? In the header, or the footer? Centered or at the outer margin?
    – Werner
    Apr 21, 2012 at 16:44
  • anywhere :) It's just for doing revisions on paper and referencing pages.
    – Sandro
    Apr 22, 2012 at 4:14

3 Answers 3

80

Put this right after \maketitle:

\thispagestyle{plain}
\pagestyle{plain}
8
  • Adding your suggestion in the document preamble creates page numbers from the first page onward.
    – Werner
    Apr 21, 2012 at 16:02
  • Not if \maketitle is used on the first page :/
    – andrew
    Apr 21, 2012 at 20:46
  • Perfect! You got it! I just wish that it worked on page 1, but it's no big. Thank you!
    – Sandro
    Apr 22, 2012 at 4:16
  • 4
    @Sandro: In order to have a page number on the first page with \maketitle, include \g@addto@macro\maketitle{\thispagestyle{plain}} between \makeatletter ... \makeatother. This is just the easiest, even though there are other page styles.
    – Werner
    Apr 22, 2012 at 5:03
  • @Werner Cool tip, any idea how to get things to show up in \@oddhead on the first page?
    – andrew
    Apr 23, 2012 at 8:00
3

For bare_journal_comsoc.tex with IEEEtran.cls, the following works.

Put this after \maketitle

\thispagestyle{empty} %--to make title page number less
\pagestyle{empty}    % -- to make other pages number less.

If you put

\thispagestyle{plain}
\pagestyle{plain}

then, numbers are still coming but at the center of the footer as in IEEE published papers.

1
2

If possible, avoiding the conference document-class option (just as another member commented above) and replacing it will comsoc will start generating page numbers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.