I'm getting natbib error:

Bibliography not compatible with author-year citations. 

The 'help' says

Check the bibliography entries for non-compliant syntax, or select author-year Bibtex style e.g. plainnat.

Can someone point out the error in my ways because apalike is an author-year style citation, right?


some text \citep{citekey1} and \citet{citekey2}


closed as too localized by lockstep, Joseph Wright Apr 22 '12 at 10:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • And I can add that the same error occurs with different bibliographic styles. Although strangely enough, when I used jponew from here it worked flawlessly the first time but not subsequently – Dominik Apr 21 '12 at 5:46
  • 2
    I don't get any error (I just used one bib database of mine). – egreg Apr 21 '12 at 8:56
  • 4
    Two ideas: try deleting the .bbl auxiliary file and reprocess your document; if that doesn't help, build a minimal .bib file that reproduces the error and add it to your question. – Gonzalo Medina Apr 21 '12 at 13:25
  • thank Gonzalo. It seems to work now. I actually didn't realize that "Trash Aux Files" in TexShop wouldn't delete the .bbl along with the .aux. I hope I don't have to do that regularly. – Dominik Apr 21 '12 at 16:30