1

The last release broke one of the styles I rely on and reverting MiKTeX seems to be faster than fixing the style.


I asked this question as I was looking for a way to binary search through releases to find which one broke the style before reporting it to the style author, @andybuckley.

I considered

  1. Using the code stored under https://github.com/MiKTeX/miktex/releases/tag [as suggested by @AndréC] but found the overhead to install the complete MiKTeX toolchain to be too much. Plus, as pointed out by @david-carlisle, this only contains the code to build MiKTeX: the packages would still be pulled from the current versions.
  2. I also looked at the MiKTeX Docker images. They are also available for only the current release (AFAICT), but are cool nonetheless.
  3. LiveTeX does maintain a complete archive: e.g., ftp://tug.org/historic/systems/texlive/2018.

LiveTeX allowed me to determine that the break comes between the 2018 and 2019 releases. If anyone is interested, here is the MWE;

\documentclass{minimal}
\usepackage{hepparticles} % the package under test
\newcommand{\Pg}{{\HepParticle{g}{}{}}} % gluon
\begin{document}
:\Pg:
\end{document}

Output under LiveTeX 2018: ":g:"; under LiveTeX 2019: "::"

The problem is also displayed when running the package test file, http://mirrors.ctan.org/macros/latex/contrib/hepparticles/testhepparticles.tex.


In the newer version, \updefault-> up, while previously it was \updefault -> n.


Found the origin: The default value of \updefault.

  • 2
    Asking google seems to be faster! – Black Mild Feb 11 at 15:09
  • 1
    Welcome to the site. While your question is a valid one, it might also be helpful to edit your question and indicate what broke with your style. There may be ready-made fixes for the issue. – Steven B. Segletes Feb 11 at 15:17
  • The issue is rather unlikely to be caused by a change in miktx itself (TeX is rather stable) but more likely to be due to a change in some tex package that you are using, so you would not just need old binaries of the tex program but the entire old package distribution server from the previous version. – David Carlisle Feb 11 at 19:20
  • Possible duplicate: Historical, stable version archive of packages – Werner Feb 11 at 21:31
  • After edition. I run your MWE and the example from the link and both worked correctly (":g:" was produced and the whole example with tons of "B"s). I have MikTeX updated at 03 Feb 2020. Could you try to download the package from CTAN hepparticles (ctan.org/pkg/hepparticles) and paste it on the same folder of your main tex file? – FHZ Feb 12 at 14:01
0

Hi @George and welcome to TeX-SE.

Although you may still find the old releases of MikTeX MiKTeX Releases, you will quickly find out that the older versions are not avaliable anymore, e.g., MiKTeX 2.4 Status.

I would strongly recommend you to ask a more specific question about the problem you are dealing with. For example, which style, class, package, etc. is not working.

1

The MikTeX source is stored on github. As Git is a version control software, previous versions are kept and can be downloaded here : https://github.com/MiKTeX/miktex/tags

screenshot

  • 1
    this is sort of true but the OPs problem is almost certainly caused by a newer latex package rather then a newer miktex binary, so to get a working "old release" would need the entire server infrastructure for installing older packages on the demand from whichever time you were rolling back to. – David Carlisle Feb 11 at 19:18
  • @DavidCarlisle You are certainly right, but obviously the OP remains deaf and dumb to these arguments similar to those of Steven B. Segletes. From now on, he will be able to verify by himself where is the true and false. – AndréC Feb 11 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.