2

I use TeXstdio to edit my TeX files and used to shift-click on a package name (in \usepackage ou \RequirePackage) to open the corresponding PDF file.

It's not working for me anymore. When I hover the mouse holding the shift-key the package name turns blue with underline, but when clicked, nothing happens.

My enviroment

  • Ubuntu eoan 19.10
  • GNOME Shell 3.34.1
  • TeXstudio 2.12.22
  • Texlive installed with the install-tl script (see comment below)

Also, both .bashrc and .profile includes

TEXDIR="/usr/local/texlive/2019"
TEXMFCONFIG="~/.texlive2019/texmf-config"
TEXMFHOME="~/texmf"
TEXMFLOCAL="/usr/local/texlive/texmf-local"
TEXMFSYSCONFIG="/usr/local/texlive/2019/texmf-config"
TEXMFSYSVAR="/usr/local/texlive/2019/texmf-var"
TEXMFVAR="~/.texlive2019/texmf-var"

I'm not currently using the apt version of texlive (from official repositories) because I just couldn't make the package translator work properly.

I wasn't able to find any configuration in TeXstudio to set the documentation search path.

How to fix this problem?

2
  • Please don't add [SOLVED] to the question title. You can accept your own answer and that's enough to show that the issue is solved.
    – campa
    Feb 17, 2020 at 12:00
  • Nice to know! Thanks.
    – Jander
    Feb 17, 2020 at 12:02

1 Answer 1

1

I've found the problem. The $PATH to the binaries needed to be set in both .bashrc and .profile.

Now everthing works just fine!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .