0

I am using Mac laptop with dark theme. TexStudio also shows in dark theme. I would like to change the editor background to

4
  • Welcome to TeX-SX! As a new member, it is recommended to visit the Welcome and the Tour pages to be informed about our format and also to know about Minimal Example.
    – R. N
    Feb 16, 2020 at 12:00
  • Otherwise have you tried something like: Option->configure TeXstudio->SyntaxHighlight->Background
    – R. N
    Feb 16, 2020 at 12:05
  • Option->configure TeXstudio->SyntaxHighlight->Background worked for me. Thanks for the comment.
    – Arunnima
    Feb 28, 2020 at 12:25
  • Actually , in Mac when I changed the theme to dark background, closed and opened TexStudio, the background shows black again. In Syntax highlighting, background color is still white. Any other way ??
    – Arunnima
    Feb 28, 2020 at 14:10

2 Answers 2

1

In TeXstudio you can change the background of the editor using: Option->configure TeXstudio->SyntaxHighlight->Background

And by save the configuration it should remain still way even after closing and reopening the application.

0

I had this problem, too, and a workaround can be found on the gitbuh community-pages here: Workaround for TexStudio DarkMode exclusion MacOS In short, use this command in the terminal to exclude TexStudio from DarkMode:

defaults write texstudio NSRequiresAquaSystemAppearance -bool yes

and this one to revert:

defaults delete texstudio NSRequiresAquaSystemAppearance

Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .