3

How can I activate the demo option for the graphicx package when using memoir? Is there an equivalent option in memoir?

When I try:

\usepackage[demo]{graphicx}

I get:

! LaTeX Error: Option clash for package graphicx

Update (solved)

Memoir does not load graphicx, so the solution is to add \usepackage[demo]{graphicx} before any other package loads graphicx, as @egreg pointed out in the comments.

  • As far as I know, the memoir class doesn't load the graphicx package, so \usepackage[demo]{graphicx} should work. It might not work if some other package loads graphicx; without seeing the preamble you're using it's impossible to say more. – egreg Apr 22 '12 at 15:28
5

As the comments point out, I can just add \usepackage[demo]{graphicx} in the preamble. The option clash has nothing to do with memoir.

I am loading other packages in the preamble which is why I believe I had the option clash. The problem was resolved when I added \usepackage[demo]{graphicx} at the beginning of the preamble (before any other packages were added).

As a reference, I was adding these packages in the preamble:

mathpazo
tikz
ragged2e
fontenc
listings
hyperref
geometry
  • 3
    You have to insert that line before calling the other package that tries to load graphicx, of course. – egreg Apr 22 '12 at 15:32
2

One solution that does not depend on the load order of the packages is to add demo as an option to the document class:

\documentclass[demo]{memoir}

\usepackage{mathpazo}
\usepackage{tikz}
\usepackage{ragged2e}
\usepackage{fontenc}
\usepackage{listings}
\usepackage{hyperref}
\usepackage{geometry}
\usepackage{graphicx}

\begin{document}
Hello World
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.