2

I was creating a PDF using cas-dc-template.tex downloaded from http://mirrors.ctan.org/macros/latex/contrib/els-cas-templates.zip

However it causes the following error:

LaTeX3 Error: '\msg_term:n' deprecated on 2020-01-01. Use '\iow_term:n '.

The error corresponds to the command \tnotetext[1]. It seems that something in \tnotetext has been deprecated on 2020-01-01. How can I solve this problem?

The same error message appears for the command \cortext[1]{Corresponding Author}.

1 Answer 1

6

The problem is, as the error message says, that \msg_term:n is deprecated. This function along with a couple others were removed from the LaTeX3 kernel because they were not correctly named.

I mailed the Elsevier team responsible for their LaTeX packages and they updated (26-02-2020) the els-cas-templates package to address this issue. With an up-to-date system you shouldn't experience this issue.


For the next few months (until July 1st, 2020) you can have \msg_term:n back by loading expl3 with undo-recent-deprecations:

\RequirePackage[undo-recent-deprecations]{expl3}
%
\documentclass{cas-dc}
\usepackage{natbib}
\begin{document}
\tnotetext[1]{}
\end{document}
8
  • 1
    thank you very much. I appreciate it.
    – user207225
    Feb 19, 2020 at 0:50
  • This actually broke compilation for me on overleaf. I downloaded the project and compiled locally and I noticed following the message "LaTeX3 Error: '\msg_term:n' deprecated on 2020-01-01. Use '\iow_term:n '." it was asking me to "Press ENTER to continue. Since overleaf compilation runs in the background this seem to just hang. Seems poor design to for a compiler to halt on user input. Not sure why I'm just seeing it now though - maybe overleaf just upgraded the latex compiler? Apr 20, 2021 at 0:48
  • @DavidWaterworth The version of cas-dc on Overleaf is updated so there is no error (I just tried): what do you mean it broke? Can you share a link to the project? On a local system it depends: what do you get when you run latex '\stop' on a terminal? TeX (which is technically not a compiler) was made for usage with a terminal, and user interaction was a major feature. Nevertheless you can run TeX with -interaction=nonstopmode to avoid interaction. Apr 20, 2021 at 1:17
  • @PhelypeOleinik I didn't use the cas-dc from overleaf, I uploaded my own copy - I wasn't actually aware it was included with the overleaf templates (I get very confused which elsevier template to use, elsarticle vs cas-dc). I cannot share the link at this stage sorry. Apr 20, 2021 at 1:43
  • 1
    @DavidWaterworth No rush. When you get to a compilable example that shows the problem, please ask a question. Should you decide to use elsarticle, I'm sure it's possible to place the ORCID somehow Apr 20, 2021 at 2:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .