1

I'm trying to cite a paper with multiple authors using APA standard using natbib.

For the initial citation, all authors should be listed, then for subsequent references it should start to use et al. I can't get this working, and the first instance of a reference appears as below:

unexpanded author citation

I've tried using both \citep{} and \citep*{}, neither expand the authors. Here's the entry as it appears in the bib file:

@article{Goodrich2009,
  year = {2009},
  month = dec,
  publisher = {American Medical Association ({AMA})},
  volume = {163},
  number = {12},
  author = {Samantha A. Goodrich and Tiffany A. Pempek and Sandra L. Calvert},
  title = {Formal Production Features of Infant and Toddler {DVDs}},
  journal = {Archives of Pediatrics {\&} Adolescent Medicine}
}

I'm using apalike as the bibliography style, but the problem still persists when using apa.

2
  • Can you please add a small example of a document?
    – egreg
    Feb 19, 2020 at 12:30
  • 1
    The apalike bibliography style is one of the "original" bibliography style files, created around the time BibTeX was created. I.e., it dates back to the early 1980s and it hasn't been changed substantially since then. Moreover, the apalike bib style predates the natbib package by more than a decade. As such, apalike is not set up to work with natbib's longnamesfirst option. As suggested in @Denis's answer, you're better off switching to the apacite bib style and eponymous citation management package.
    – Mico
    Feb 19, 2020 at 14:02

1 Answer 1

1

Try using apacite

\documentclass[12pt]{article}
\usepackage[natbibapa]{apacite}
\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@article{Goodrich2009,
  year = {2009},
  month = dec,
  publisher = {American Medical Association ({AMA})},
  volume = {163},
  number = {12},
  author = {Samantha A. Goodrich and Tiffany A. Pempek and Sandra L. Calvert},
  title = {Formal Production Features of Infant and Toddler {DVDs}},
  journal = {Archives of Pediatrics {\&} Adolescent Medicine}
}
\end{filecontents*}

\begin{document}
Dummy text here \citep{Goodrich2009}

\citet{Goodrich2009}

\bibliographystyle{apacite}
\bibliography{\jobname}
\end{document} 

to obtain

enter image description here

2
  • Don't load both apacite and natbib. (Hint: It suffices to load apacite with the option natbibapa.)
    – Mico
    Feb 19, 2020 at 14:07
  • @Mico Right! I am updating the anwser.
    – Denis
    Feb 19, 2020 at 14:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .