2

On Debian bullseye/sid, I upgraded my texlive install (version 2019.20191208-4 - testing) but biber (2.13-1) is broken:

Ex (see source files below):

> pdflatex foo.tex

compiles normally (and suggests to run biber) then

> biber foo

has output:

Unsuccessful stat on filename containing newline at /usr/share/perl5/XML/LibXML/Simple.pm line 232.
data source % biber.conf [2011/07/17 v0.1f biblatex-juradiss]
% Release Notes can be found in the README.txt


<map>
  <bibtex>
   <globalfield>
     decision        usera
     sign            userb
     officialvolume  userc
     officialpages   userd
     journalyear     usere
     decisionname    userf
   </globalfield>
  </bibtex>
</map>
 not found in .

This happens, for instance with this foo.tex:

\documentclass{article}
\usepackage{biblatex}
\addbibresource{bar.bib}
\begin{document}
Hello \cite{bla2014} World.
\printbibliography
\end{document}

and bar.bib:

@book{bla2014,
   title =     {Bla bla},
   author =    {John Doe},
   publisher = {De Boeck},
   year =      {2014}
}

I tried to install other versions of biber but it is not really feasible due to incompatibility with texlive-bibtex-extra or other packages in Debian.

For some reason, the default biber.conf seems to be the BibLaTeX stylefiles for German law thesis:

kpsewhich biber.conf
/usr/share/texlive/texmf-dist/doc/latex/biblatex-juradiss/biber.conf

so I also tried to create a biber.conf file in . by copying the xml file described in http://mirrors.ibiblio.org/CTAN/biblio/biber/documentation/biber.pdf but it is for 2.14 and does not work either.

Any idea of what I can do?

Thanks for your help.

Lancelot

8
  • Surely this is something you should report to the Debian TeX live/Biber maintainers.
    – moewe
    Feb 19 '20 at 20:55
  • Posting here was a suggestion from a biber maintener but if there is a better place, I will ask there of course.
    – lancelot
    Feb 19 '20 at 20:57
  • All I can say is that the biber.conf from biblatex-juradiss is completely outdated (not unlike the rest of biblatex-juradiss) and not compatible with a current Biber. I'm a bit surprised that kpsewhich biber.conf finds files in the /doc subtree of the TeX live tree.
    – moewe
    Feb 19 '20 at 21:06
  • OK thanks. Actually I searched, without success, for the proper biber.conf in v2.13 to copy it to . hoping that it could possibly allow to circumvent the problem.
    – lancelot
    Feb 19 '20 at 21:17
  • 1
    On my vanilla TeX live (from TUG.org) on Ubuntu kpsewhich biber.conf does not find doc/latex/biblatex-juradiss/biber.conf even though it is installed. (It was my understanding that kpsewhich does not search the doc subtree by default). Contact the Debian TeX live maintainers and ask them if this is an intentional change. (This is not a Biber issue as such, so the Biber developer probably can't help you here: The Biber Debian maintainer would be more relevant, but I think this is a Debian TeX live issue).
    – moewe
    Feb 19 '20 at 21:20
1

Thank you for your useful comments! Indeed, the problem was due to an old dirty hack I forgot I made on environment variables. From older TeX installations, I did not use TEXMFHOME and used a custom TEXINPUTS that was not set properly and had :/usr/share/texlive/texmf-dist//: as a substring. I unset TEXINPUTS, moved my TeX stuff to $MYDEVPATH/texmf and set TEXMFHOME=$MYDEVPATH/texmf.

Now everything works fine!

2
  • Can you tell us more about that dirty hack, so other people are warned against it? In the current form the question and answer don't really help other people.
    – moewe
    Feb 20 '20 at 6:57
  • Nothing fancy but sure, I'll edit the post.
    – lancelot
    Feb 20 '20 at 6:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.