I was writing a document and everything was fine, but suddenly I get "not cited" errors when I try to add new citations. I can insert the citation, but it shows not cited!

enter image description here

I checked everything. The bib file and the style file are there and chosen in the bibliography. I also checked the bib and LaTeX log, but nothing is shown there.

The LyX Version is, and I am using basic BibTeX, with IEEEtran.bst. I tried different options and styles, but they weren't helpful.

  • Welcome to TeX.SE! Best would be to show us the TeX code Lyx generates for a small example file resulting in your issue. Then people having/using Lyx can copy that code, test that code on the own computer and work with it to catch the error ... Simply help us to help you ...
    – Mensch
    Feb 24, 2020 at 23:27

1 Answer 1


Changing citation style to [#ID] solved the issue. enter image description here

It was on add to bibliogrophy only before that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .