14

In the Messages box of TeXstudio, I get the following output:

Process started: pdflatex.exe -synctex=1 -interaction=nonstopmode "my latex file".tex

pdflatex: major issue: So far, no MiKTeX administrator has checked for updates.

Process exited normally

I ran miktex-console_admin.exe, clicked "Check for updates" and updated the packages, but this annoying "pdflatex: major issue: ..." message does not go away.

8
  • 2
    Sorry but your question is not understable. Try to describe your problem better. – Ulrike Fischer Feb 28 '20 at 17:11
  • OK, edited the question. Hope it is clearer now. – Peter Jan Randewijk Feb 28 '20 at 17:21
  • Try to compile on a command line. If you get the message there too, ask in the miktex issue tracker. – Ulrike Fischer Feb 28 '20 at 17:23
  • Yes, it is also in the command line, unless I run it with "-quiet". So I added "-quiet" in TeXstudio's PdfLaTeX command, and now at least the annoying message is gone. But I will post this anyway in the MikTeX issue tracker. Thanks for helping. – Peter Jan Randewijk Feb 28 '20 at 18:30
  • 1
    As of MiKTeX 2.9.7300, this warning will show up if 1. MiKTeX was installed for all users 2. the system wide MiKTeX update check is pending A similar message will be displayed if admin/user packages are out-of-sync To get rid of the warning message, you have to switch to MiKTeX administrator mode and then check for MiKTeX updates. – Christian Schenk Feb 29 '20 at 11:08
13

I had a similar issue on a new install of MikTeX 2.9.7300 on Windows 7. I received the error message

So far, no MiKTeX administrator has checked for updates.

The error persisted even after

  • opening MikTeX Console from the Windows Start Menu,
  • clicking Switch to MikTeX administrator mode,
  • and checking for updates.

What resolved the issue for me was to start the MikTeX console using Administrator privileges. Specifically I

  • opened the Windows Start Menu to the MikTeX 2.9 section,
  • right-clicked on MikTex Console and selected Run as administrator from the context menu,
  • in MikTeX Console selected Switch to MikTeX administrator mode,
  • and checked for updates.

Of course YMMV and I imagine there are other ways to do this.

3

As @Malcolm suggested, each user should update his database to get rid of this message. For instance, my MikteX installation has two users:

  • the administrator (with administrative privileges), which updates the database under C:\Program Files\MiKTeX 2.9,

  • and a user (with restricted permissions) with a database under C:\Users\name\AppData\Roaming\2.9

I seldom use the user account for whatever MikteX related works. Nevertheless, if I update my database by adding a new package, for example, I do run the Check for updates then Updates for each MikTeX users to synchronize all databases.

For more info, check: https://miktex.org/kb/fix-user-admin-updates-out-of-sync.

2
  • Please, make your answer self-contained (that is: include all relevant instructions in here), because external links can eventually become invalid – Alessandro Cuttin May 11 '20 at 14:59
  • 1
    Just updated the answer. I hope it is now self-contained. – Scadh May 12 '20 at 15:47
1

I just came across this problem on the command line, BUT there are no updates in either the user or the administrator accounts when running MiKTeX console.

To be precise: Compiling a document resulted in automated downloads of several packages into the user space. I also installed the same packages into the administrator (system) space. These were within minutes of each other, so the version should be the same.

Attempted solutions: 1. Running updmap in the user space results in updmap: major issue: User/administrator updates are out-of-sync 2. Running MiKTeX console as administrator shows 0 updates. This was followed by refresh the filename database and refresh the font map files under Tasks, and checking for updates again. 3. Running MiKTeX console as user shows 0 updates. This was followed by refresh the filename database and refresh the font map files under Tasks, and checking for updates again. 4. Running updmap in the user space, after 2 and 3 above, results in updmap: major issue: User/administrator updates are out-of-sync 5. Running updmap as administrator, results in updmap: security risk: running with elevated privileges initexmf: security risk: running with elevated privileges initexmf: security risk: running with elevated privileges updmap: major issue: So far, you have not checked for updates as a MiKTeX user.

This is very confusing

OK, so I just tried another option that resolved the conundrum.

It is necessary to first run updmap --admin as administrator. That is, open a CMD terminal with Adminstrator privileges and execute the command in thet terminal.

Then the problem in userspace is resolved, i.e., updmap in userspace executes without error.

2
  • Not a question, but so closely related that the comment might be useful for someone. Rather than opening another thread, thought it useful to keep it in one place. (I also brought my solution into the same comment -- still learning to work with the interface.) – Gerard Tromp May 31 '20 at 15:56
  • The bit after "OK, so..." just solved it for me: run updmap --admin in administrator mode. – kyle Feb 28 at 3:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.