1

I've introduced some parts in my file that are coded like this : \part*{title of the part}. So, in order to have them added to the Table of content, I use : \addcontentsline{toc}{part}.

But I'm facing something strange with the following lines :

enter image description here

If I'm correct I've not changed many thing between the code for "Conclusion" and the one for "Annexes et Tables". So I don't see the problem...

But If I do this :

enter image description here

So, both entries appear in the ToC but "Annexes et Tables" appears before I actually introduce the \part*{Annexes et Tables} line of code...so That's not what I want and both have the same page number which is not a problem while I've not written any of those two parts but when i'll have finished down the line, I'll be stuck...

And if I push my luck as far as deleting \part*{Annexes et tables}, just to see what happens :

enter image description here

Both lines disappear in the PDF file...

Just to give a further piece of information : i've got at the beginning of my document a non-numbered part called "Introduction" and that one suffer from no problem at all. So I don't know what's causing this problem here....

Thanks for your help,

Regards,

Elrad

5
  • Will there be any numbered or unnumbered sectioning commands following \part*{Annexes et Tables}?
    – leandriis
    Mar 4, 2020 at 21:29
  • Yes there will be some` \chapter*{...}` under the \part*{Annexes et Tables} part Mar 4, 2020 at 21:33
  • As soon as I add a \chapter* or any other sectioning command after the \part*{Annexes...} the table of contents will displayed correctly, provided that I use your first approach.
    – leandriis
    Mar 4, 2020 at 21:36
  • 1
    Here is a MWE: \documentclass{memoir} \begin{document} \tableofcontents \part*{Conclusion} \addcontentsline{toc}{part}{Conclusion} \part*{Annexe} \addcontentsline{toc}{part}{Annexe} \chapter*{some chapter} \end{document}
    – leandriis
    Mar 4, 2020 at 21:36
  • @leandriis your idea is the good one, if I simply introduce another element after that unnumbered part, it works. Thanks for answering. Mar 5, 2020 at 13:50

1 Answer 1

1

If you are using \addcontentsline... to put a title into the ToC then that code should be placed after you have coded for the title in the document.

% lots of stuff
% \addcontentsline{toc}{part}{Title} % not this
\part*{Title}
\addcontentsline{toc}{part}{Title}   % but this
1
  • that's what I did in my first example albeit separated by green dots like this%----% Mar 7, 2020 at 6:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .