3

For the following MWE:

\documentclass{beamer}
\usetheme{metropolis}
\setbeamertemplate{footline}{}
\makeatletter
\def\beamer@framenotesbegin{% at beginning of slide
\usebeamercolor[fg]{normal text}
\gdef\beamer@noteitems{}%
\gdef\beamer@notes{}%
}
\makeatother
\usepackage{lmodern}
\usepackage{tcolorbox}
\usepackage[USenglish]{babel}
\usepackage[latin1]{inputenc}
\usepackage{bigdelim}
\setbeamersize{text margin left=10mm,text margin right=10mm} 
\setbeamerfont{frametitle}{size=\small}
\begin{document}
\maketitle

\begin{frame}{Spectral Properties}
\resizebox{\textwidth}{!}{%
\begin{tabular}{r@{\,}|c|c|}
\cline{2-3}
& \textbf{Column 1}\footnotemark[1] & \textbf{Column 2}\footnotemark[2]\\
\cline{2-3} \cline{2-3}
\color{green}\ldelim\{{3}{*}[\color{red} Info]&
Some Text & Some Text\\ \cline{2-3}
\onslide<2->{&Some Text  & Some Text\\ \cline{2-3}}
\onslide<3->{&Some Text & Some Text \\ \cline{2-3}}
\end{tabular}
}
\end{frame}
\end{document}

I get the output:

Table

What is the stray vertical line doing in all the frames? How do I get rid of it?

1 Answer 1

5

Here is one of the many ways to do that. (See here and in its linked posts for earlier discussions.) EDIT: In order to avoid jumps, one can add the [t] option to the frame.

\documentclass{beamer}
\usetheme{metropolis}
\setbeamertemplate{footline}{}
\makeatletter
\def\beamer@framenotesbegin{% at beginning of slide
\usebeamercolor[fg]{normal text}
\gdef\beamer@noteitems{}%
\gdef\beamer@notes{}%
}
\makeatother
\usepackage{lmodern}
\usepackage{tcolorbox}
\usepackage[USenglish]{babel}
\usepackage[latin1]{inputenc}
\usepackage{bigdelim}
\setbeamersize{text margin left=10mm,text margin right=10mm} 
\setbeamerfont{frametitle}{size=\small}
\begin{document}
\maketitle

\begin{frame}[t]
\frametitle{Spectral Properties}
\resizebox{\textwidth}{!}{%
\begin{tabular}{r@{\,}|c|c|}
\cline{2-3}
& \textbf{Column 1}\footnotemark[1] & \textbf{Column 2}\footnotemark[2]\\
\cline{2-3} \cline{2-3}
\color{green}\ldelim\{{3}{*}[\color{red} Info]&
Some Text & Some Text 
\only<2->{\\ \cline{2-3} &Some Text  & Some Text}
\only<3->{\\ \cline{2-3} &Some Text & Some Text}
\\ \cline{2-3}
\end{tabular}
}
\end{frame}
\end{document}

enter image description here

Another trick is to make the offending line white.

\documentclass{beamer}
\usetheme{metropolis}
\setbeamertemplate{footline}{}
\usepackage{colortbl}
\makeatletter
\def\beamer@framenotesbegin{% at beginning of slide
\usebeamercolor[fg]{normal text}
\gdef\beamer@noteitems{}%
\gdef\beamer@notes{}%
}
\makeatother
\usepackage{lmodern}
\usepackage{tcolorbox}
\usepackage[USenglish]{babel}
\usepackage[latin1]{inputenc}
\usepackage{bigdelim}
\setbeamersize{text margin left=10mm,text margin right=10mm} 
\setbeamerfont{frametitle}{size=\small}
\begin{document}
\maketitle

\begin{frame}
\frametitle{Spectral Properties}
\resizebox{\textwidth}{!}{%
\begin{tabular}{r@{\,}|c|c|}
\cline{2-3}
& \textbf{Column 1}\footnotemark[1] & \textbf{Column 2}\footnotemark[2]\\
\cline{2-3} \cline{2-3}
\color{green}\ldelim\{{3}{*}[\color{red} Info]&
Some Text & Some Text\\ \cline{2-3}
\onslide<2->{&Some Text  & Some Text\\ \cline{2-3}}
\onslide<3->{&Some Text & Some Text \\ \cline{2-3}\arrayrulecolor{white}}
\end{tabular}
}
\end{frame}
\end{document}

enter image description here

3
  • Thanks! I had tried the \noalign{\pause} earlier but it was messing with my footnotes. \alt helps remove the stray vertical line but why do they change the size of the table in each slide? Mar 8, 2020 at 1:25
  • @SahibaArora True. You can avoid jumps, though, by adding the [t] option to the frame (I do that in all my frames precisely because I like to use \pause), or just make the last, stray line white.
    – user194703
    Mar 8, 2020 at 1:37
  • Many thanks! \arrayrulecolor was the perfect solution for me :) Mar 8, 2020 at 2:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .