1

My knowledge of LaTeX is not very much up to date, but I've learned to use italics correction (\/) whenever you do not want ligatures to be used, like for \textit{Farbauf\/lösung} (for non-Germans: The word means "color resolution", and you would hyphenate between "f" and "l", so the ligature seems bad). When rendering with pdflatex I get something like this:

Rendering of "Farbauflösung"

However when I use \section{Auf\/lösungsvermögen}, the I don't see that effect.

I read in some common (la)tex errors that italics correction is not needed within \texit in most cases, but still is in some cases. That isn't really helpful to me, so what's going on and what to do?

  • 1
    If you use babel, the correct way should be Farbauf"|lösung – egreg Mar 10 at 22:21
  • 1
    You're fast ;-) Actually I'm using \usepackage[german]{babel}, so what does that "| mean? – U. Windl Mar 10 at 22:23
  • If you (a) don't want to perform ligature suppression manually and (b) are able to use LuaLaTeX, you may want to look into using the selnolig package, which performs suppression of selected ligatures for german and english documents. E.g., try running \documentclass[ngerman]{article} \usepackage{fontspec,babel,selnolig} \begin{document} \itshape Farbauflösung \end{document} under LuaLaTeX. – Mico Mar 11 at 12:18
5

This is the description of the shorthands available with babel-german. Several of them are no longer really needed with UTF-8 input.

In your case, to separate word fragments at a morpheme boundary, the construct to use is "|. It also adds a possible hyphenation point, according to the rules of German.

enter image description here

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[german]{babel}

\begin{document}

\textit{Farbauf"|lösung}

\end{document}

Note also that \usepackage[ngerman]{babel} does some adjustments to conform to Neue Rechtschreibung. Pick the option that best suits you.

Output using \textit{Farbauf"|lösung}

Note:

Remember to quote " and | when using it for an \index entry (like \index{Farbauf'"'|lösung} when using quote '\'').

| improve this answer | |
  • Should I replace even those \/ outside of \textits? OK, it works fine, but when also adding it to the index, I get a somewhat funny auf" . . . . . . . . . . . . . . . . łösung for \index{Farb-!auf"|lösung} (before I just had had \index{Farb-!auflösung}). Suggestions? – U. Windl Mar 10 at 22:45
  • @U.Windl That's a different question altogether. – egreg Mar 10 at 22:46
  • 2
    @U.Windl " and | are special characters for MakeIndex and they should be quoted with ": \index{Farb-!auf"""|lösung} – egreg Mar 10 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.