2

I need to cite classical authors using only shorthands in chicago-authordate style. I use autocite for this. There should be no date and no author name. Otherwise my institute's style roughly follows the chicago manual.

My problem is very similar to this question, except that my document uses babel's [ngerman]-option. When I use the shorttitle-field instead of the shorthand-field, the linked answer does nothing in my citations but replace "(Author Shorttitle)" with "(Author Title)". Using shorttitle also does not specify which shorttitle is used for which source - it doesn't show in the bibliography and I don't have the option to print a list of shorthands. So I would prefer using the shorthand-field to keep those options. But using shorthands has the following problems:

  1. The citation contains both the shorthand and the full title. It should only be the shorthand (and any pre-/post-notes, of course).
  2. The shorthand gets printed in the bibliography, but gets overwritten by a line (along with the author) if I cite two works of the same author. In case a bibentry has a shorthand, this line shouldn't overwrite it. (It may keep overwriting the author if there's no shorthand.)
  3. Both shorthand and title are omitted if I cite the same source more than once per page. I would like the shorthand to always be used.
  4. [When using shorthand, there appear parenthesis around the author in the bibliography, which would be nice to get rid of. (Maybe related to the bibmacro "shorthand:author"?) Not essential, however, my style sheet gives no specific recommendation here.]

If you provide a solution, I would be even more grateful if you could just point out which part of your code does what.

MWE (using only the shorthand-field):

\begin{filecontents}{ref.bib}

@mvbook{lev,
    title={Leviathan},
    subtitle={The matter, form, and power of a commonwealth ecclesiastical and civil},
    author={Hobbes, Thomas},
    maintitle={The English works of Thomas Hobbes of Malmesbury},
    volume={3},
    date={1839},
    editor={Molesworth, William},
    publisher={Bohn, John},
    location={London},
    shorthand={LE},
    entrysubtype={classical}
}

@mvbook{dc,
    title={De Corpore},
    author={Hobbes, Thomas},
    booktitle={Elements of philosophy},
    maintitle={The English works of Thomas Hobbes of Malmesbury},
    volume={1},
    date={1839},
    editor={Molesworth, William},
    publisher={Bohn, John},
    location={London},
    shorthand={DC},
    entrysubtype={classical}
}

@book{lockeEssay,
  author={Locke, John},
  title={An essay concerning human understanding},
  date={1999},
  editor={Manis, Jim},
  publisher={Pennsylvania State University},
  location={Hazleton},
  shorthand={Essay},
  entrysubtype={classical}
}

\end{filecontents}  
\documentclass[12pt,a4paper]{article}  
\usepackage[ngerman]{babel}  
\usepackage[utf8]{inputenc}        
\usepackage[babel=true]{csquotes}  
\usepackage[T1]{fontenc}           
\usepackage{filecontents}  
\usepackage{blindtext}  
\usepackage[authordate,backend=biber]{biblatex-chicago}  
\addbibresource{ref.bib}

\begin{document}

\blindtext \autocite[I.4]{lev} 

\blindtext \autocite[I.4]{lev} \autocite[I.ii.1]{dc}

\autocite[I.4]{lev} \autocite[]{lockeEssay} \autocite[II.2.1]{lockeEssay}

\printbibliography  
\end{document}
2

biblatex-chicago is quite a complex style, so it can be tricky to customise it beyond its own extensive set of options and user-definable behaviour.

  1. Can be changed with the cmslos option. With cmslos=false, citations of entries with a shorthand only show the shorthand.
  2. Together with cmslos=false, we actually don't get the shorthand in the bibliography any more at all. Indeed, the standard biblatex way to resolve shorthands is with a separate list of shorthands produced with \printbiblist{shorthand}.

    If you want to retain the shorthand in the normal bibliography and fix the dash issue, you need something like

    \renewbibmacro*{shorthand:author}{%
      \iffieldundef{shorthand}
        {}
        {\csundef{bbx@lasthash}%
         \printfield{shorthand}%
         \setunit*{\addspace}}}
    

    Note that this already resolves item 4, because that redefinition doesn't set the toggle cms@authorparens any more, which caused the author to appear in parentheses.

    You may want to think about making the shorthand stand out a little more in the bibliography. For example with \DeclareFieldFormat{bibshorthand}{\mkbibbold{#1}} (replace \printfield{shorthand}% with \printfield[bibshorthand]{shorthand}% in \renewbibmacro*{shorthand:author} for that to work).

  3. Apparently, it is Chicago style only to print the page reference and no "ibid." or other citation marker for ibidem references. See also Printing "ibid" for biblatex-chicago authordate style. The "ibid" feature can be turned off either with biblatex-chicago's noibid option or by disabling the tracker with ibidtracker=false. (I'll use ibidtracker=false, because that is more 'portable' across styles and the exact implementation of the noibid option is a bit ... interesting.)

  4. See 2.

MWE (shorthands in bibliography)

\documentclass[12pt,a4paper]{article}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[babel=true]{csquotes}
\usepackage[T1]{fontenc}
\usepackage[authordate,backend=biber,cmslos=false,ibidtracker=false]{biblatex-chicago}


\renewbibmacro*{shorthand:author}{%
  \iffieldundef{shorthand}
    {}
    {\csundef{bbx@lasthash}%
     \printfield{shorthand}%
     \setunit*{\addspace}}}

\begin{filecontents}{\jobname.bib}
@mvbook{lev,
    title={Leviathan},
    subtitle={The matter, form, and power of a commonwealth ecclesiastical and civil},
    author={Hobbes, Thomas},
    maintitle={The English works of Thomas Hobbes of Malmesbury},
    volume={3},
    date={1839},
    editor={Molesworth, William},
    publisher={Bohn, John},
    location={London},
    shorthand={LE},
    entrysubtype={classical}
}
@mvbook{dc,
    title={De Corpore},
    author={Hobbes, Thomas},
    booktitle={Elements of philosophy},
    maintitle={The English works of Thomas Hobbes of Malmesbury},
    volume={1},
    date={1839},
    editor={Molesworth, William},
    publisher={Bohn, John},
    location={London},
    shorthand={DC},
    entrysubtype={classical}
}
@book{lockeEssay,
  author={Locke, John},
  title={An essay concerning human understanding},
  date={1999},
  editor={Manis, Jim},
  publisher={Pennsylvania State University},
  location={Hazleton},
  shorthand={Essay},
  entrysubtype={classical}
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
Lorem \autocite[I.4]{lev}

ipsum \autocite[I.4]{lev} \autocite[I.ii.1]{dc}

\autocite[I.4]{lev} \autocite[]{lockeEssay} \autocite[II.2.1]{lockeEssay}

\printbiblist{shorthand}
\printbibliography
\end{document}

citations only with shorthands, bibliography includes shorthands

MWE (separate list of shorthands)

\documentclass[12pt,a4paper]{article}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[babel=true]{csquotes}
\usepackage[T1]{fontenc}
\usepackage[authordate,backend=biber,cmslos=false,ibidtracker=false]{biblatex-chicago}


\begin{filecontents}{\jobname.bib}
@mvbook{lev,
    title={Leviathan},
    subtitle={The matter, form, and power of a commonwealth ecclesiastical and civil},
    author={Hobbes, Thomas},
    maintitle={The English works of Thomas Hobbes of Malmesbury},
    volume={3},
    date={1839},
    editor={Molesworth, William},
    publisher={Bohn, John},
    location={London},
    shorthand={LE},
    entrysubtype={classical}
}
@mvbook{dc,
    title={De Corpore},
    author={Hobbes, Thomas},
    booktitle={Elements of philosophy},
    maintitle={The English works of Thomas Hobbes of Malmesbury},
    volume={1},
    date={1839},
    editor={Molesworth, William},
    publisher={Bohn, John},
    location={London},
    shorthand={DC},
    entrysubtype={classical}
}
@book{lockeEssay,
  author={Locke, John},
  title={An essay concerning human understanding},
  date={1999},
  editor={Manis, Jim},
  publisher={Pennsylvania State University},
  location={Hazleton},
  shorthand={Essay},
  entrysubtype={classical}
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
Lorem \autocite[I.4]{lev}

ipsum \autocite[I.4]{lev} \autocite[I.ii.1]{dc}

\autocite[I.4]{lev} \autocite[]{lockeEssay} \autocite[II.2.1]{lockeEssay}

\printbiblist{shorthand}
\printbibliography
\end{document}

citations with shorthands, separate list of shorthands and bibliography

3
  • Great answer, thanks a lot. Out of curiosity: When the shorthands are in the bibliography and one is longer than the others ("Essay"), is there an easy way to realign the bibliography entries (comparable to how it looks in the shorthand list)?
    – MrBubbles
    Mar 12 '20 at 22:28
  • @MrBubbles Yes-ish. The question is what you want to do with items that don't have a shorthand. You could say something like \DeclareFieldFormat{bibshorthand}{\makebox[\shorthandwidth][l]{#1}} and use \printfield[bibshorthand]{shorthand}% instead of \printfield{shorthand}% (as explained in item 2), then items with shorthand are indented, but items without are not indented. That may look a bit odd. ...
    – moewe
    Mar 13 '20 at 6:43
  • ... A conceptually nicer solution would redefine the bibliography environment to add the shorthand as in the list of shorthands (basically as itemize labels). But then entries without a shorthand would just leave this first bit of the list blank, that might look even more odd.
    – moewe
    Mar 13 '20 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.