0

I am a beginner and I am trying to use OSCOLA Style with biblatex. It's 2 days I am bashing my head on these errors:

enter image description here

Please help!

1
  • 2
    For future questions, please note that it is much better to post the code of your (ideally minimal) example document (and the errors) as text instead of uploading an image. Images can be hard to read, are not searched by search engines and pose a severe accessibility issue for people with screen readers. Images of code are particularly discouraging, because they require people to re-type your code before they can test it and play around with it. – moewe Mar 11 '20 at 17:10
1

Update

The issue is resolved in oscola v1.7 (2020/03/15) (see https://github.com/PaulStanley/oscola-biblatex/pull/8).

If possibly update your TeX system to obtain a current version of oscola.

The rest of the answer below is kept for historical interest.


This error occurs, because someone extended the scope of some of biblatex's standard.bbx options from global to per-type and per-entry, see https://github.com/plk/biblatex/pull/877 and https://github.com/plk/biblatex/issues/875 for background (https://github.com/plk/biblatex/pull/866 for even more background). Amongst the options whose scope was extended are url, doi and eprint.

biblatex will not accept attempts to define an option if it has been defined before and will throw an error. oscola already defines the options url, doi and eprint at per-type and per-entry scopes.

Unfortunately, someone forgot to check oscola for compatibility with the change, so the biblatex update went out before the oscola author could be made aware of this change and adapt his style.

The issue was only discovered a while later by Ulrike Fischer (https://chat.stackexchange.com/transcript/41?m=52383705#52383705) and for now documents using style=oscola, will complain

! Package biblatex Error: Option 'url' already defined.

See the biblatex package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.135   \settoggle{bbx:url}{#1}}
                                
? 

! Package biblatex Error: Option 'doi' already defined.

See the biblatex package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.137   \settoggle{bbx:doi}{#1}}
                                
? 

! Package biblatex Error: Option 'eprint' already defined.

See the biblatex package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.139   \settoggle{bbx:eprint}{#1}}
                                   
? 

because biblatex's standard.bbx defines these options and then oscola.bbx tries to define them again.

A fix has been submitted to the oscola-biblatex GitHub repository: https://github.com/PaulStanley/oscola-biblatex/pull/8.

If you need to use oscola now, download oscola.bbx from the pull request (https://github.com/PaulStanley/oscola-biblatex/blob/28e6a54ef5c6d4b02e06cedee0123d7b92ec5857/oscola.bbx), put it into the same folder as your main .tex document, rename it to oscola-fixed.bbx and load biblatex as

\usepackage[bibstyle=oscola-fixed, citestyle=oscola, backend=biber]{biblatex}

instead of \usepackage[style=oscola, backend=biber]{biblatex}.

1
  • OOOOOMYGOOODDDDDDDDD!!!!! YES it works!!!!!!!!!!!! I am sooooooo happyyyyyyyyy!!!!!! Yes YEs YES! Thank you soOOOoOOOOOOooooooOOOO much! – lea Mar 12 '20 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.