0

I am writing the supporting information of a paper whose template can be downloaded here

Basically, it is in draft mode :

\documentclass[draft, grl]{agutexSI2019}

But I also add after this:

\usepackage{graphicx}
%
%  Uncomment the following command to allow illustrations to print
%   when using Draft:
\setkeys{Gin}{draft=False}
%

As a result, figures outside figure environment (those not floats) show:

\includegraphics[scale = 1]{dummyfig.pdf}

but those inside figure environment doe not:

\begin{figure}
  \includegraphics[scale = 1]{dummyfig.pdf}
  \caption{test}
  \label{Figure_sand_pile}
\end{figure}

Any hint ?

0

The class does

\ifjdraft%
\expandafter\ifx\csname setkeys\endcsname\relax\else
\setkeys{Gin}{draft=false}\fi

so sets the graphics back to draft mode in at least a couple of places

Probably you can do this:

\makeatletter
\setkeys{Gin}{draft=false}
\define@key{Gin}{draft}[true]{}
\makeatother

so you disable the key after setting it the way you want, further uses of draft=anything do nothing.

2
  • It does not makes floating figures appear :/ To be sure, I typed : \usepackage{graphicx} \makeatletter \setkeys{Gin}{draft=false} \define@key{Gin}{draft}[true]{} \makeatother
    – Liris
    Mar 13 '20 at 10:29
  • 1
    @Liris hmm you didn't supply a test file (questions should always have a test file, you can use example-image as the image) so this was untested but as far as I could see that should work. An alternative, would be to simply edit your local copy for the class and comment out every use of \setkeys{Gin}{draft} Mar 13 '20 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.