1

JabRef bibliography manager was recently updated (March 6, 2020) to version 5.0. For windows system (WIN10 ver. 1909), the update installer file this time was given as msi file JabRef-5.0.msi rather than the usual exe extension JabRef_windows-x64_4_3_1.exe used in previous updates.

When trying to install the new update file JabRef-5.0.msi, the following error message is displayed

There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor.

enter image description here

When clicking OK and Next, the setup is finished without installing anything.

The following solutions have been tried:

  • Empty internet temporary folder
  • Update Java to the recent version (jre-8u241-windows-x64)

None of them worked.

Is there any idea what's wrong?

6
  • Hi, please try uninstalling the old JabRef version before and then again the new version. If it does not help, try running it as administrator (right click on the msi) Mar 16, 2020 at 7:07
  • 1
    Thanks Chris. I've already tried that solution. Unsuccessful.
    – hesham
    Mar 16, 2020 at 16:45
  • There is no need to update Java as JabRef 5.0 comes with pre-bundled Java.
    – koppor
    Mar 17, 2020 at 6:34
  • 1
    Workaround: Use the portable version. - Just extract the zip file into your Documents folder (or somewhere else)
    – koppor
    Mar 17, 2020 at 6:35
  • An issue was opened about this topic on the developer's website github.com/JabRef/jabref/issues/6141. If a solution is obtained, I will update everyone here.
    – hesham
    Mar 17, 2020 at 15:02

1 Answer 1

2

The problem is solved by opening the command prompt cmd as administrator, then running the installer with the command line msiexec /i "path\to\JabRef-5.0.msi"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .