13

I'm using biblatex to manage my citation in a natbib style :

\usepackage[style=alphabetic,maxnames=6,natbib=true]{biblatex}

However when I use the \citet command, the author's name is in a \textsc font, I would like to change this behavior so that the font used is the default one, but I could not find how to do this in biblatex's documentation.

  • 2
    Please provide a minimal working example. – Thorsten Apr 25 '12 at 16:40
18

I guess you're also using \usepackage[french]{babel}? The French module in biblatex (french.lbx) formats last names in small capitals by providing this "local" definition of the \mkbibnamelast command:

\protected\def\mkbibnamelast#1{\textsc{\textnohyphenation{#1}}}

To restore this command to its "global" definition add the following to your preamble:

\DefineBibliographyExtras{french}{\restorecommand\mkbibnamelast}

In biblatex.def the global definition is:

\newcommand*{\mkbibnamelast}[1]{#1}

You can redefine this via \renewcommand*. The code in \DefineBibliographyExtras is hooked into citation commands and bibliography drivers. So the French definition will simply be restored to the "current" global definition.

| improve this answer | |
  • You are right, I am indeed using babel french. This answers perfectly my question! – Pascal Apr 27 '12 at 13:48
5

Update (with babel-french v. 3.2a 2016-03-18)

The command \DefineBibliographyExtras{french}{\restorecommand\mkbibnamelast} no longer works.

To disable small caps in names in french language, add in the preamble the following command:

\DefineBibliographyExtras{french}{\restorecommand\mkbibnamefamily}
| improve this answer | |
  • 3
    See also Biblatex 3.3 name formatting for a survey of other changes in biblatex 3.3. The issue is not with babel-french, but rather with biblatex 3.3. – moewe Mar 30 '16 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.