3

I want to make a presentation where at the beginning of each section the table of contents is displayed. I am doing the presentation in dutch, so I want the title of those frames to be 'Overzicht'. I'm using the following code:

\documentclass{beamer}
\usepackage[utf8]{inputenc}

\AtBeginSection[]
{
  \begin{frame}
    \frametitle{Overzicht}
    \tableofcontents[currentsection]
  \end{frame}
}

\usetheme[kul]{kuleuven2}
\setbeamertemplate{footline}[body]

\title{De leegheid van de soritesparadox}
\author{Lukas Rollier }
\date{26 Maart 2020}

\begin{document}

\maketitle

\section{Soritesparadox}

\section{Taaldarwinisme}

\end{document}

But the title on those frames remains 'outline'.

5
  • 2
    I don't have your beamer theme kuleuven2. With the standard theme your code works fine for me.
    – luki
    Commented Mar 21, 2020 at 11:54
  • 1
    Any reason why you don't load the package babel with the option dutch? Commented Mar 21, 2020 at 11:59
  • Is the beamer theme kuleuven2 available online somewhere?
    – Mico
    Commented Mar 21, 2020 at 12:05
  • I tried using the babel package. That doesn't work. The beamer theme is available here: kuleuven.be/communicatie/marketing-en-communicatie/en/templates/… Commented Mar 21, 2020 at 12:20
  • First solution, place your \AtBeginSection definition after usetheme command. This way, your definition will substitute one defined in kuleuven2 theme.
    – Ignasi
    Commented Aug 24, 2020 at 16:51

4 Answers 4

3

Beamer uses translator package to automatically translate certain words to whatever language you use. But to do this, a dictionary file is needed and there is no one for Dutch.

The best solution would be to define them, but as a quick solution you could use something like this:

\documentclass[dutch]{beamer} %<- ducth is applied to beamer and babel
\usepackage[utf8]{inputenc}
\usepackage{babel}

\usetheme[kul]{kuleuven2}
\setbeamertemplate{footline}[body]

\deftranslation[to=Dutch]{Outline}{Overzicht} %<- your translation. add as many as you need

% This is the definition at kuleuven2 theme
    \AtBeginSection[] {
        \begin{frame}
            \frametitle{\translate{Outline}} %<--- Apply translator to "Outline"
                {
                \hypersetup{hidelinks} %disable link colors
                \hfill  {\large\parbox{.95\textwidth}{\tableofcontents[currentsection,hideothersubsections]}}
                }
        \end{frame}
    }
    
\title{De leegheid van de soritesparadox}
\author{Lukas Rollier }
\date{26 Maart 2020}

\begin{document}

\maketitle

\section{Soritesparadox}
\begin{frame}{test}
\end{frame}

\section{Taaldarwinisme}

\begin{frame}{test}
\end{frame}

\end{document}

enter image description here

2

As pointed out (indirectly) by H.K. the issue here is that the creator of the template hardcoded the definition of \AtBeginSection into the .sty file including the English frametitle.

This is the only place in the .sty file, where any text has been defined, so it makes a lot of sense, to make this babel-friendly.

This can easily be achieved by adding:

\addto\captionsdutch{\renewcommand{\contentsname}{Overzicht}}
\addto\captionsenglish{\renewcommand{\contentsname}{Outline}}

right before the \AtBeginSection in the .sty file AND replacing line 246 with:

\frametitle{\contentsname}

That way, users can easily switch between the Dutch and English version (both of which default to other terms for the table of contents making it necessary to define the new frametitles, otherwise replacing line 246 like suggested would have been sufficient).

1

Just change the loading order.

\documentclass{beamer}
\usepackage[utf8]{inputenc}

\usetheme[kul]{kuleuven2}
\setbeamertemplate{footline}[body]

\AtBeginSection[]
{
  \begin{frame}
    \frametitle{Overzicht}
    \tableofcontents[currentsection]
  \end{frame}
}


\title{De leegheid van de soritesparadox}
\author{Lukas Rollier}
\date{26 Maart 2020}

\begin{document}

\maketitle

\section{Soritesparadox}

\section{Taaldarwinisme}

\end{document}

enter image description here

0

Quick and (very) dirty, you might change the file 'beamerthemekuleuven2.sty' (after a backup), replacing 'Outline' in line 242 by 'Overzicht'.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .