2

In Lyx, when I go to view -> Code Preview Plane, it likes to break my sentences with justification.

enter image description here

How can I stop the Code Preview from inserting line breaks for justification?

  • The automatic line breaks of the LyX edit screen and of the automatic line breaks of the source code are both irrelevant, since the automatic line breaks in the compiled PDF will change again, because they are all ... automatic. Moreover, since you cannot edit the latex code directly from LyX, nor it is necessary at all, why the hell do you care about? – Fran Mar 22 at 0:09
  • I'm taking a class where I have to answer using LaTeX online, but the website's editor is basically notepad so I'm using Lyx as a simple way to write solutions easily, then I can just copy the source code into the website. – James Palmer Mar 22 at 0:13
2

Note that the following will change the line length for your exported LaTeX as well. I don't know if there are consequences to that.

  1. Go to Tools > Preferences > Output > General and set "Output line length" to 0.

Step 1

  1. Press "OK".

The results should show immediately:

Result

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.