0

I use the {tufte-book}documentclass and I write my document in french language with usepackage[french]{babel}. Unfortunatly the margin notes and the bibliography references remains in english, as well as the formatting of the legends of the figures and tables. Does anybody could help me to apply the french langage on all the document ?

\documentclass[symmetric,justified,marginals=raggedouter]{tufte-book}
\usepackage{microtype}
\usepackage{fancyvrb}
\usepackage[utf8] {inputenc}
\usepackage[T1]{fontenc}
\usepackage[french]{babel}

\begin{document}

\bibliographystyle{plainnat}
\bibliography{sample-handout}

\end{document}

This is an example of the problem above. You can see in the fourth note that there is a "and" in place of "et" and the word "edition" in place of "édition" :

enter image description here

  • 1
    Did you try specifying the french option with the document class rather than with babel (as should be)? – Bernard Mar 22 at 13:22
  • Please provide something that is self contained and actually show your problem. – daleif Mar 22 at 13:23
  • Also please explain what you mean by ` bibliography references remains in english` bibtex styles are not know to support babel, so they are mainly in english. You miht want to have a loot at biblatex instead. – daleif Mar 22 at 13:28
  • 1
    As mentioned plainnat is english only. You will need to find a style that supports french and supports natbib. – daleif Mar 22 at 14:13
0

I found a solution !! I have to use the bibliographystyle{plain-fr}

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.