1

I'm trying to build a simple PDF document with an interactive formular using the eform package, following this documentation: http://mirror.las.iastate.edu/tex-archive/macros/latex/contrib/acrotex/doc/eformman.pdf

My main focus is on the checkboxes, because I need them for my application.

Based on the documentation I build this small example acroforms.tex:

\documentclass{article}
\usepackage[dvips]{eforms}

\everyCheckBox{\BC{.690 .769 .871}\BG{.941 1 .941}\textColor{1 0 0}}

\begin{document}
    % Content containing form fields, such as...
    Don't \pushButton[\CA{Push Me}]{myButton}{}{12bp},
    I fall down easily.

    This is my checkbox:
    \checkBox[\symbolchoice{circle}]{myCheck}{10bp}{10bp}{On}
\end{document}

And build it with this makefile on Linux Mint 19.3 using MikTex 2.9.7050:

all: acroforms.pdf

acroforms.pdf: acroforms.ps
    ps2pdf -dEmbedAllFonts=true acroforms.ps

acroforms.ps: acroforms.dvi
    dvips acroforms.dvi

acroforms.dvi: acroforms.tex
    pdflatex -output-format=dvi acroforms.tex
    pdflatex -output-format=dvi acroforms.tex

The PDF viewer Evince is able to render it correctly. However, the build in reader in Vivaldi (Chromium), and the java library PDFBox, developed by Apache, are not able to render the form.

Screenshots: enter image description here

Nevertheless, all three applications (Evince, Chromium & Apache PDFBox) are able to render the original pdf of the documentation correctly. Since they are all able to render the documentation, I assume the problem on my side.

Screenshots: enter image description here

I also tried to use the hyperref package directly with the exact same result. What am I missing?

  • I don;t think any of the webbased PDF viewers supports these features. We tested them out at one point to use a form based PDF for an exam. And had to conclude that on linux Evince would work, not much else. Adobe reader would work on windows, not much else. – daleif Mar 23 at 15:28
  • I'm rather sure that the author of eforms uses distiller to produce the documentation, so there could be differences to the ps2pdf output. If you have access to distiller you could try it instead. The ghostscript of miktex is a bit old (9.25), you could try a newer one. – Ulrike Fischer Mar 23 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.