I have a document containing some 1-column and 2-column passages, mixed, e.g.:

This sentence has no column-

This part of   are balanced
the document   such that t-
has two col-   he lines are
umns which     equal.

This part of the document
has no columns. The text is
like normal.

I am using a code like this:

    This sentence has no columns.
    This part of the document has two columns which are balanced such that the lines are equal.
    This part of the document has columns. The text is like normal.

When I compile this code, the last paragraph is placed on a new page, but it seems there should be enough space that it can appear on the same page.

  • How can I ensure that no page break is added at the end of the column set?
  • 2
    This looks like a bug. If you don't need anything fancy (different widths for columns, spanning columns, etc), you can try regular columns: \startcolumn ... \stopcolumn
    – Aditya
    Commented Apr 27, 2012 at 4:09
  • @JosephWright: I am not sure which column implementation (ConTeXt has three or four of them) is the best solution for the OP, so I was actually waiting for his reply whether columns work for his use case or not.
    – Aditya
    Commented Jul 8, 2013 at 19:26

1 Answer 1


You cannot mix columnsets with regular text. If you want a single column text in a document using columnset, you will have to define a span. Another option is to use \startcolumns or its replacement \startmixedcolumns.



\input ward

  \input ward

\input douglas

  \input knuth


The result:

Mixed Columns

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .