I'm trying to install the pbox package on my MiKTeX 2.9 installation, and failing miserably. The miktex package manager fails with the message "Remote file not found". I got the package from http://www.ctan.org/tex-archive/macros/latex/contrib/pbox and tried to make it, but it attempts to run /usr/bin/install which isn't on my Windows machine.

What should I do? Is anyone else able to install pbox?

2 Answers 2


You don't need any extra binaries to install such a package. Since you have the files run tex (or latex) on pbox.ins this will input pbox.dtx and generate pbox.sty which is the package file you are after. If it is in the current directory it should just work with your document. You can latex pbox.dtx to get the documentation if you do not already have it (the ready made pdf is already on ctan).

  • That's excellent news, I'll give it a whirl. How do I make it so that I don't have to have the .sty in my PWD? Commented Apr 27, 2012 at 15:03
  • 1
    that would depend on how miktex manages TEXINPUTS but I don't use miktex, but actually if you want that it's probably best to fix the package manager install then miktex will "know" it is there, and handle future updates more cleanly. I gave the answer I did as often it's useful to know that packages not needing fonts etc don't really need installation you just need a local copy of the file. Commented Apr 27, 2012 at 15:39

I just installed pbox with the miktex package manager without any problems. I used the repository at the fu berlin.

  • Okay, so it must be an installation problem on my end. After pdflatex.exe: Remote file not found I get ! LaTeX Error: File 'pbox.sty' not found. Thanks for testing that for me. Commented Apr 27, 2012 at 15:03
  • 1
    I just saw in your link that you are probably using the portable version of miktex. I don't know much about this version. Your problem could be due to a broken repository. So at first try to switch to another one. If this fails try to install from a local folder see my answer here tex.stackexchange.com/questions/45653/… Commented Apr 28, 2012 at 9:07
  • Well, happy me for descriptive directory names :) . I was able to install a dependency of pbox (I forgot what it's called) and I've installed a number of other packages without issue. I've tried lots of repository servers. I've tried to install from a local folder (get from ctan, then run make) but make tries to run /usr/bin/something which I don't have. I recently thought that I should try the posix windows subsystem to see if I can get it to work. Anyway, I compiled the .sty and placed in my local directory. Thanks for the help! Commented Apr 28, 2012 at 17:05
  • 1
    make? That's certainly not the correct way on a windows system. Use the package manager and choose the folder with the two miktex-zz...-files and the pbox.tar.lzma as local repository. Commented Apr 28, 2012 at 17:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .