0

I am new to Latex and I am using Overleaf. I wonder how I can remove hyperlinks from my reference list (bibliography)?

I am using the Hyperref package, and use the \cite to reference documents which are in a separate, large Bibtex file. I am using \hypersetup{nolinks=true} in the header to remove links, but it does not work!

Here is how I load and use the packages (the header of my file):

\documentclass[runningheads]{llncs}

\usepackage{listings}
\usepackage{graphicx}

\usepackage[hyphens]{url}
\usepackage{hyperref}
\hypersetup{nolinks=true}

%\hypersetup{breaklinks=true}
%\Urlmuskip=0mu plus 1mu

Is it possible that this happens because I am using the LNCS template? Because it tells the references to follow its style, where it wants to add the bibliography (reference list):

\bibliographystyle{splncs04}
\bibliography{my_ref.bib}

Thanks

PS:Also, here is how my current bibliography looks like. I want the links gone: enter image description here

  • 1
    I get no links with your class and the hyperref option. Show a screenshot of a link you are getting. – Ulrike Fischer Apr 1 at 8:04
  • @UlrikeFischer Added to the original question – RFNO Apr 1 at 9:03
  • There is nothing that shows that there are active links. Or do you want the printed text http://... to go away? – Ulrike Fischer Apr 1 at 9:08
  • @UlrikeFischer Yes, that's what I want. – RFNO Apr 1 at 9:10
  • That has nothing to do with hyperref, it only makes the links active, it doesn't print them. Your bibliography style inserts the urls and to really suppress them you should either change the bst or use a different style. You could try \makeatletter\def\url@#1{}\makeatother before the bibliography, but you will probably get some stray commas in the bibliography. – Ulrike Fischer Apr 1 at 9:19
0

I am still new to Latex myself but what I have found is this

\hypersetup{colorlinks=false}

This will not remove the link, but hide the colour of the links in the printed version (pdf) which already might be what you need.

| improve this answer | |
  • Thanks, but this does not work either! – RFNO Apr 1 at 7:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.