restricted system commands enabled.

Sorry, but "C:\MiKTeX 2.9\miktex\bin\x64\miktex-luatex.exe" did not succeed.

The log file hopefully contains the information to get MiKTeX going again:


And then in that file:

2020-04-03 05:14:32,286-0600 INFO  miktex-luatex - starting with command line: "C:\MiKTeX 2.9\miktex\bin\x64\miktex-luatex.exe" -synctex=1 --fmt=lualatex doubleSidedCards.tex
2020-04-03 05:14:32,354-0600 INFO  miktex-luatex - going to create file: lualatex.fmt
2020-04-03 05:14:32,643-0600 ERROR miktex-luatex - C:\MiKTeX 2.9\miktex\bin\x64\initexmf.exe did not succeed; exitCode: 1
2020-04-03 05:14:32,643-0600 ERROR miktex-luatex - output:
2020-04-03 05:14:32,643-0600 ERROR miktex-luatex - 
Sorry, but "MiKTeX Configuration Utility" did not succeed for the following reason:

  Unknown format name/engine: lualatex/luatex

The log file hopefully contains the information to get MiKTeX going again:


2020-04-03 05:14:32,644-0600 FATAL miktex-luatex - The memory dump file could not be found.
2020-04-03 05:14:32,644-0600 FATAL miktex-luatex - Info: fileName="lualatex.fmt"
2020-04-03 05:14:32,644-0600 FATAL miktex-luatex - Source: Programs\TeXAndFriends\luatex\miktex\miktex.cpp
2020-04-03 05:14:32,644-0600 FATAL miktex-luatex - Line: 74
2020-04-03 05:14:32,644-0600 INFO  miktex-luatex - finishing with exit code 1

I did try reinstalling miktex which actually worked for about two compilations. Then I updated miktex and we're right back to not being able to run lualatex. I am on Windows 7 running 64-bit miktex. It seemed to work okay if using an engine other than lualatex. Unfortunately that's what I'm using.

Oh yeah I did the classic update, rebuild names database, rebuild formats in miktex console but obviously that does nothing.

  • 1
    Just for fun and because this is often a problem on miktex. Did you update miktex in both miktex user mode and miktex admin mode? The user mode stuff might not get touched by a reinstall. – daleif Apr 4 '20 at 5:44
  • 2
    Your formats.ini probably still points to luatex instead of luahbtex. Check what is said about lualatex in settings->formats – Ulrike Fischer Apr 4 '20 at 7:14

I had the same problem days ago. On the MikTeX website they explain that they are introducing a new Lua compiler (LuaHB). In the case of LuaLaTeX this is found in: "miktex-portable / texmfs / install / miktex / bin / x64 / miktex-luahbtex.exe"

I updated the instructions to compile in TeXworks and lualatex.fmt is found (portable installation) in: "... \ miktex-portable \ texmfs \ data \ miktex \ data \ le \ luahbtex \ lualatex.fmt"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.