0

I constructed a figure with TikZ in a tufte-book document class, and I need to use the ulem package as follows

\documentclass[symmetric,justified,marginals=raggedouter]{tufte-book}
\usepackage{ulem,tikz}
\usetikzlibrary{automata,positioning,arrows.meta,shapes,calc}
\usetikzlibrary{positioning}
\usetikzlibrary{decorations.pathreplacing,calligraphy}

\usepackage{glossaries}
\makeglossaries
\newglossaryentry{latex}
{
name=latex,
description={Is a mark up language specially suited 
for scientific documents}
}

\begin{document}
\Gls{latex}
\printglossaries
\end{document}

I'm having problems using the package ulem, which has two consequences:

  1. the first is that the glossary entries are no longer edited, only the descriptions are edited!

  2. the second is that the formatting of the bibliographic references in the page notes has been modified (underlining of the titles of the references).

How to correct these faults? I specify that I write using Overleaf (I do not think I have access to the codes of the tufte-book class ...).

  • 3
    Either don't load ulem at all (i.e. make \usepackage{ulem,tikz} read \usepackage{tikz}) if you don't need it or load it with the normalem option (i.e. split \usepackage{ulem,tikz} into \usepackage[normalem]{ulem}\usepackage{tikz}). If ulem is loaded without the normalem option it will redefine \em and \emph to produce underlined text instead of the standard italics. (Nothing in the code you have shown suggests that you need to use ulem, but of course there may well be some passages of your document that need it.) – moewe Apr 7 at 19:26
  • BTW: There is a typo in the MWE \begin{document] should be \begin{document} – moewe Apr 7 at 19:28
0

The comment of moewe give the good results. Thanks

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.