1

I'm trying to add a dotless j and get a black box.

\documentclass[openany,twoside]{scrbook}
\usepackage[scaled]{helvet}
\usepackage{mathptmx}
\usepackage{multicol}
\usepackage{tipa}
\usepackage{imakeidx}
% index options
% \makeindex[options=-s dots,intoc]
\usepackage{soul}
\usepackage{siunitx}
\begin{document}\j\end{document}

How do I get the dotless j?

2
  • 1
    If you remove \usepackage{mathptmx} you get it. (I am not saying this is a real solution, but if you try $\jmath$ with \usepackage{mathptmx} you even get an error.)
    – user194703
    Commented Apr 9, 2020 at 2:44
  • mathptmx is one of an old font package, please switch to txfonts is advisable...
    – MadyYuvi
    Commented Apr 9, 2020 at 4:42

1 Answer 1

2

please switch to newtxtext and newtxmath will solve the issue,

If still you want to use mathptmx, then the below code may helps you:

\documentclass[openany,twoside]{scrbook}
\usepackage[scaled]{helvet}
\usepackage{mathptmx}
\usepackage{multicol}
\usepackage{tipa}
\usepackage{imakeidx}
% index options
% \makeindex[options=-s dots,intoc]
\usepackage{soul}
\usepackage{siunitx}
\usepackage{dotlessj}
\begin{document}
\j\quad j

\end{document}

Output

enter image description here

3
  • 3
    newtxtext and newtxmath, instead of txfonts
    – egreg
    Commented Apr 9, 2020 at 8:32
  • @egreg oops..sorry, I'll update myself...and thanks a lot...
    – MadyYuvi
    Commented Apr 9, 2020 at 8:52
  • So I guess it was just me being dumb with my packages...
    – merrybot
    Commented Apr 9, 2020 at 17:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .