2

I am having the following issue when the word analysis is hyphenated in TeX.

enter image description here

This is using \usepackage[british]{babel} in the header. I have figured out how to work around the issue, by manually setting the hyphenation:

\usepackage{hyphenat}
\hyphenation{a-na-ly-sis}

Still, I am curious why this is not handled automatically. Beyond the obvious undesirable connotation of this hyphenation, it seems to me that the "ly" in analysis should definitely belong together.

7
  • When did you last update your TeX distribution? With MacTeX2019 and \usepackage[british]{babel}, I get ana-lysis and ana-lytic.
    – Mico
    Apr 10, 2020 at 6:32
  • @Mico I'm on texlive 2019
    – TheChymera
    Apr 10, 2020 at 6:40
  • 1
    I get ana-lysis as the only suggested break point. (Fully updated MikTeX with LaTeX2e <2020-02-02> patch level 5, L3 programming layer <2020-04-06>)
    – moewe
    Apr 10, 2020 at 6:59
  • 2
    Run the minimal example posted by Mico and upload the complete .log file to a text-sharing website such as pastebin.com
    – moewe
    Apr 10, 2020 at 7:12
  • 2
    To retrieve the available languages, add the option showlanguages to babel (ie, \usepackage[british, showlanguages]{babel}. They are listed in the .log file. Apr 10, 2020 at 11:02

2 Answers 2

4

Your installation of TeX Live is missing the support for UK English.

How to add it on Gentoo Linux is difficult to say; check https://packages.gentoo.org/packages/dev-texlive/texlive-langenglish

I can reproduce the issue if I remove the support for UK English:

\makeatletter
\let\l@UKenglish\@undefined
\let\l@ukenglish\@undefined
\let\l@british\@undefined
\makeatother

\documentclass{article}
\usepackage[british]{babel}

\showhyphens{analysis}

This produces

Underfull \hbox (badness 10000) in paragraph at lines 10--10
[] \OT1/cmr/m/n/10 anal-y-sis

because, when a language which is not provided with hyphenation patterns is requested, babel will use language 0 (US English).

After removing the initial lines I get

Underfull \hbox (badness 10000) in paragraph at lines 12--12
[] \OT1/cmr/m/n/10 ana-lysis

because my installation does have support for UK English.

2
0

(too long for a comment, hence posted as an answer)

I am unable to replicate the issue you have encountered with either TeXLive2019 (with all updates applied, LaTeX2e <2020-02-02> patch level 5, babel 2020/02/28 3.41, and british 2017/06/06 v3.3r) or with TeXLive2020 (pre-release version, same LaTeX2e and babel versions as above).

enter image description here

When did you last update your TeX distribution, and which versions of babel and the british language support block does your document employ?

\documentclass{article}
\usepackage[british]{babel}
\usepackage{hyphenat} % optional
\setlength\textwidth{1sp}
\begin{document} 
\hspace{0pt}analysis analytic Arseneau % as in 'Donald Arseneau'
\end{document}
5
  • This is the latest texlive version available on Gentoo Linux, installed just a few days ago: Installed versions: 2019-r1(01:25:00 AM 04/02/2020). Could it be some subpackage, or is this really baked into texlive?
    – TheChymera
    Apr 10, 2020 at 6:57
  • @TheChymera - I'm afraid I have no idea how up-to-date the Gentoo Linux distribution may be. (I use MacOS 10.15.4 "Catalina" and both MacTeX2019 and MacTeX2020.) What information can you glean from the log file regarding the version of LaTeX2e, babel, and the 'british' language module that get employed when you compile the document that features the unfortunate hyphenation instance?
    – Mico
    Apr 10, 2020 at 7:04
  • 2
    @Mico Suggestion: add showlanguages to the babel options. Apr 10, 2020 at 11:06
  • @Mico with your code I get this log: chymera.eu/debug/tex/hyphenation/full_with_babel.log and this output document: chymera.eu/debug/tex/hyphenation/fulltest.pdf
    – TheChymera
    Apr 10, 2020 at 18:42
  • @TheChymera - Thanks. According to the log file, your TeX system has an out-dated version of the LaTeX2e format (<2018-12-01>; current is <2020-02-02> patch level 5) and copies of unknown vintage of the babel package and of the british module. Any chance you could run sudo tlmgr update --self --all from a command prompt and recompile the document?
    – Mico
    Apr 10, 2020 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.