19

I'm using MiKTeX 2.9 and TeXnicCenter 1.0-RC1 (Windows 7) and try to compile the following minimal code:

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage{ccicons}
\begin{document}
 \ccbysa
\end{document}

I installed the ccicons-package using the MiKTeX Package Manager (MPM). TeXnicCenter gives 0 errors, 0 warnings - nothing, but doesn't even create any PDF output. Reading the log-file shows the following fatal error:

!pdfTeX error: C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\pdflatex.exe (file ccicons): Font ccicons at 600 not found ==> Fatal error occurred, no output PDF file produced!

While browsing the net for this error, I came across this question: Font installed, compiles to dvi, but fails compiling to pdf. "font at 600 not found" - which is quite the same problem that I have.

The suggested solution is to run updmap-sys --enable Map=ccicons.map or updmap --enable Map=ccicons.map but this is obviously linux command line notation. Running this from a Windows command prompt I will always get the following message:

mkfntmap: --enable: unknown option

I also tried -enable or /enable but still the same result. So, my question, what is the correct command for Windows users? (It's quite strange as MiKTeX is originally designed for Windows, isn't it?)

The ccicons readme also suggests running updmap --enable Map ccicons.map ... Any ideas?

  • There's some seriously weird stuff going on here. Can someone explain what all this mapping is about and why I can't just install the font package and compile happily everafter? This doesn't seem to be too rare a problem, after all... – jhin Feb 12 '16 at 13:20
23

Without any hope of success ;-) You can try the following steps.

  1. Edit the map configuration file updmap.cfg. In a Command Prompt window, run:

    initexmf --edit-config-file updmap
    

    You'll want to edit this in a text editor such as Notepad. If the file or any of the leading directories do not exist, create them.

  2. Add this one line to updmap.cfg and save it:

    Map ccicons.map
    
  3. Back at the command prompt, run:

    initexmf --mkmaps
    

    (Ignore any error messages.)

These steps were described as I bought the font Lucida

| improve this answer | |
  • Will do as soon as I have 15 reputation! :) – Afr Apr 30 '12 at 13:19
  • For everyone coming here for the same problem with tgpagella: Using Map rm-qplr.map instead solved the problem for me. – jhin Feb 12 '16 at 13:18
8

The message means that the map-file has not been activated correctly. Normally this happens because

  • The miktex package is defective. In this case must add it manually as described by Marco.

Or

  • You have a multiuser installation, but a local pdftex.map. In this case you must call updmap everytime you installed a font to update this local pdftex.map.

In this case the miktex package is defective. I have made a bug report.

| improve this answer | |
  • Hi Ulrike, indeed, Marco's answer helped me to fix this. If you filed a bug report, do you mind sharing the link to the issue? I'm interested to follow this. Thanks. – Afr Apr 30 '12 at 12:37
  • 1
    sourceforge.net/tracker/… – Ulrike Fischer Apr 30 '12 at 13:21
2

On latest version of MikTeX, it is possible to force update of the font map files and font map database. You open the console and two actions are available in Task menu: - Refresh file name database - Refresh font map files

This solved the issue on my side (Font umvs at 600 not found)

| improve this answer | |
  • I had the error (Windows-MiKTeX): “Font xxxx... not found” (I don´t remember the font) and effectivelly, I´ve open the console and in Task menu I´ve apply the options "Refresh file name database" and "Refresh font map files" and it work out. – wmora2 Oct 12 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.